summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-25 23:47:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-25 23:47:23 +0100
commit6bcb5a76562075ab4106d76198336727ca3b95ea (patch)
tree4edf3f14fc529265782bfd7cca235a737fd7016e
parentdev-python/botocore: Bump to 1.24.8 (diff)
downloadgentoo-6bcb5a76.tar.gz
gentoo-6bcb5a76.tar.bz2
gentoo-6bcb5a76.zip
dev-python/boto3: Bump to 1.21.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2f77cc2f6386..9fc3a23275ec 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -11,3 +11,4 @@ DIST boto3-1.21.4.tar.gz 470233 BLAKE2B 3e6d8c5264ac66829e468633700e155ac935aae9
DIST boto3-1.21.5.tar.gz 470454 BLAKE2B 850f7237b8063f0cf40d53c986b94ef571e7aa7bdcfeb2b7d4aec54a1874b1c3c7e95cb4b317e8f0ea84a809083223d32c419291d7702b51781ef0140436cb45 SHA512 c10fb11ca3db4d23806232190b4f5431efedb8601af0aa28f6e62178ae98b2b22c73e05b4d91a9f7ea3e9dce15304397e780f396a155b0e02623590af87a9905
DIST boto3-1.21.6.tar.gz 471833 BLAKE2B 7e029b9bf460696344d26a863c4d96a2c9445ab3869aa17edc1ebb42d52260105406e7fb562046b395fd66a40ca6a15221c2ee1825caebebb27eadf667ba0bf6 SHA512 ae53081cb02588b0088b20ea75c6f09f9d4fcabb1c45d0aaeba9b92ea4c1e29bea7b5b9d08b4dc8a221d6126f71944083c4dc29490e8014e5780abadc45f2f7a
DIST boto3-1.21.7.tar.gz 472869 BLAKE2B 39ea1a39bb033678c50ec5a36d30c354d65397c3d3ec8a0f771a539a8f97371ab5feea8c3e99b77f460d6a6b81a8e1b3123ceb2edb1d97459755882e3e30e237 SHA512 46dc9cd67329a27171f593c9ad95bccad7027e52419178c62e719a90b968e4b4c51e965b26e8e1e877f3b95199e63840c408a763e453963e92cde16ad0c6aff5
+DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.8.ebuild b/dev-python/boto3/boto3-1.21.8.ebuild
new file mode 100644
index 000000000000..08e404dd41b6
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}