summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-06 12:05:22 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-06 12:05:22 -0400
commit6bd4e0701716352b5c9cc6c716cf05d5b6211fde (patch)
treea3725e9a1a31aebe805a24d19658adc0d86c26c3
parentdev-db/sqlitebrowser: amd64 stable (diff)
downloadgentoo-6bd4e0701716352b5c9cc6c716cf05d5b6211fde.tar.gz
gentoo-6bd4e0701716352b5c9cc6c716cf05d5b6211fde.tar.bz2
gentoo-6bd4e0701716352b5c9cc6c716cf05d5b6211fde.zip
dev-php/pecl-stomp: Revbump for 7.2 support
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..dc494fe74045
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+PHP_EXT_NAME="stomp"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+
+DEPEND="${DEPEND}
+ php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
+ php_targets_php7-2? ( dev-lang/php:7.1[ssl?] )
+"
+
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 ; then
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ )
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}