summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-29 19:52:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-29 19:57:15 +0100
commit6be3928e68b153e70e12d22fbf37eea5cb05dd7d (patch)
tree09fd88a77e6bb85f9ac88ba6d020567e013c7d9c
parentdev-python/emcee: Add GH remote-id (diff)
downloadgentoo-6be3928e68b153e70e12d22fbf37eea5cb05dd7d.tar.gz
gentoo-6be3928e68b153e70e12d22fbf37eea5cb05dd7d.tar.bz2
gentoo-6be3928e68b153e70e12d22fbf37eea5cb05dd7d.zip
dev-python/enrich: Deselect broken test
Closes: https://bugs.gentoo.org/865497 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/enrich/enrich-1.2.7-r1.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/dev-python/enrich/enrich-1.2.7-r1.ebuild b/dev-python/enrich/enrich-1.2.7-r1.ebuild
index ad1c89166978..14a58873620b 100644
--- a/dev-python/enrich/enrich-1.2.7-r1.ebuild
+++ b/dev-python/enrich/enrich-1.2.7-r1.ebuild
@@ -4,20 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 pypi
DESCRIPTION="Extend rich functionality"
-HOMEPAGE="https://github.com/pycontribs/enrich"
+HOMEPAGE="
+ https://github.com/pycontribs/enrich/
+ https://pypi.org/project/enrich/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~riscv ~x86"
-RDEPEND="dev-python/rich[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/rich[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # known breakage in dev-python/rich
+ # https://github.com/Textualize/rich/issues/2172
+ # https://github.com/pycontribs/enrich/issues/40
+ src/enrich/test/test_console.py::test_rich_console_ex
+)