summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-04-01 13:49:54 +0200
committerMatthias Maier <tamiko@gentoo.org>2023-04-13 10:15:48 -0500
commit6bfd636764ea497216c0d3a80417b07ef5afaa30 (patch)
tree6eef902313774e0c7c85027cfd9789e86d545cc6
parentapp-emacs/nxml-libvirt-schemas: Add 9.2.0 (diff)
downloadgentoo-6bfd636764ea497216c0d3a80417b07ef5afaa30.tar.gz
gentoo-6bfd636764ea497216c0d3a80417b07ef5afaa30.tar.bz2
gentoo-6bfd636764ea497216c0d3a80417b07ef5afaa30.zip
dev-python/libvirt-python: Add 9.2.0
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/30565
-rw-r--r--dev-python/libvirt-python/Manifest2
-rw-r--r--dev-python/libvirt-python/libvirt-python-9.2.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 455064094d44..68406eba26a6 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -4,3 +4,5 @@ DIST libvirt-python-8.8.0.tar.gz 236523 BLAKE2B 56504045d4c44c2419fb8f97b1c147f1
DIST libvirt-python-8.8.0.tar.gz.asc 833 BLAKE2B 2769a404916227ce9d77ec0e76d2985b67f7e59e3f280486b59f9a9edb4fe5405ae22dd03c2d4c9f1c620a977eef90ec8fdc93d3891d8824021a226a0581cb9a SHA512 edeace09e2de739d318f63ac7b33f814ac3d2e4ad7a32164fb0691723b4872d64bc60d0f96baf1809158e76fd7dbbff75c6ee4e9112b1ba6c264287c36d691b4
DIST libvirt-python-8.9.0.tar.gz 240769 BLAKE2B 992f02fe584f33ea5bd91a28338e281d49515bae392d5209e07a916b9449965c753b9a12b2f4d8433069efc1e3c5907a378e3e2d8ee1d55ab682a3e983b2eca3 SHA512 f13767528518189bb4a6094dc029f3dee16179a269b25f1224ba448569e3a2f8b036124711060d4dda8de0f7719474a700b616e1e8e8d29028d585c2a631aa32
DIST libvirt-python-8.9.0.tar.gz.asc 833 BLAKE2B 690613f7f558155db56a5194042bdf49e004143b2066bcaccb48fc9082364a88b5f8d4112623095838a116817a55e34e8ca29e01221299efc396fb1501a060ae SHA512 a490284745c948d87f0239b70257b5cd66ae2515a4f3f33c05a2b3e1ccc28e2769c8c61d45e4f855b595a6d82b6d73e50bcd00a8bbfc7cb7fbe1a4969e48e17b
+DIST libvirt-python-9.2.0.tar.gz 243411 BLAKE2B 4478060de12fe78dc60505cbfdc9a38d398ea3860e9a1a146379695f6ed7ec21d8840b54e6a716b1177e422a934ec5dfd86365208147515f70bc02c605c32b8c SHA512 24abeb7ec27135c30cdf751476b091b89b3aa2e448f6fe57d29064e1465a49944b2c0bb19cb01ce4d728036c9387bb244594816a9853a00b1d43d89dd7f94cd5
+DIST libvirt-python-9.2.0.tar.gz.asc 833 BLAKE2B 8f09ba2399fa083d41c979354dd72ca0c44047f46c6117b08cf823d8fc7ba5a2bfa031e51855238865dc08eb77846362d200d362e8675049f32b635e40bb25cc SHA512 4cb0bffaaa95e93cff1dd2f35f0219bc97567e21e04778b6f5bd0b33aa3523cea43f5fd7d95da73ba82f695b2cab8c771a5adbd9511e8a6deeb13e7e80fe7aa2
diff --git a/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild
new file mode 100644
index 000000000000..25f4ff942c9e
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+MY_P="${P/_rc/-rc}"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libvirt.org.asc
+inherit distutils-r1 verify-sig
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:="
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz
+ verify-sig? ( https://libvirt.org/sources/python/${MY_P}.tar.gz.asc )"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+ verify-sig? ( sec-keys/openpgp-keys-libvirt )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}