summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-10 09:22:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-10 09:26:11 +0200
commit6c05177a0f18ae1f2468ac9e993a9c6bfb950cf6 (patch)
tree21c740d4042cbf0d7297258b7d8492b4387ec0ac
parentdev-python/pysnmp: Add python3_7 support (diff)
downloadgentoo-6c05177a.tar.gz
gentoo-6c05177a.tar.bz2
gentoo-6c05177a.zip
dev-python/imapclient: Bump to 2.1.0
Closes: https://bugs.gentoo.org/571310 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imapclient/Manifest1
-rw-r--r--dev-python/imapclient/files/imapclient-2.1.0-py36-tests.patch28
-rw-r--r--dev-python/imapclient/imapclient-2.1.0.ebuild44
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/imapclient/Manifest b/dev-python/imapclient/Manifest
index 38d18b9e8f3b..a41559c4199f 100644
--- a/dev-python/imapclient/Manifest
+++ b/dev-python/imapclient/Manifest
@@ -1 +1,2 @@
DIST IMAPClient-0.13.tar.gz 102427 BLAKE2B f087b6e89c45810f359bed889345e6748ebf9ae90f6e3c4e013097a4e57d3f5ab0ec21906cfdccc03a344d92ccc442d58e38e687cd0761d86956047e89fedb03 SHA512 daebaf7f4180b6c9c6f4a486b313abfdd06f3ed8ece18a19bf46a50e56c2094e85de8a8e4efb8850566378eba016c10816611d03852caf637ee1d43f3c8a418f
+DIST imapclient-2.1.0.tar.gz 85925 BLAKE2B 9725be7988c4bec105fda73389241e39e6c006bccd8130125b280041d13becd6a71a1832763171daf25dfb4e7b4a7fc86c0a3afa93216c3dc4370b19348c0a5e SHA512 57e5824504f2667cf41ac4983130e16a5ea73ea37f29cdb16295eb725b56eda55db26a12e380acb579ef6b8540d38ae6badac5dd5b644d4419cbe9151f634e70
diff --git a/dev-python/imapclient/files/imapclient-2.1.0-py36-tests.patch b/dev-python/imapclient/files/imapclient-2.1.0-py36-tests.patch
new file mode 100644
index 000000000000..d9a429a27671
--- /dev/null
+++ b/dev-python/imapclient/files/imapclient-2.1.0-py36-tests.patch
@@ -0,0 +1,28 @@
+From 26fb9c9794ad0b2541320d71d5704fce5642a53c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 10 Aug 2019 09:15:37 +0200
+Subject: [PATCH] test_imapclient: Fix LoggerAdapter version check
+
+The LoggerAdapter behavior change has been backported into Python 3.6.4.
+Update the check to expect logger.log() call in 3.6.4+ rather than 3.7+.
+
+Fixes #383.
+---
+ tests/test_imapclient.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_imapclient.py b/tests/test_imapclient.py
+index 91ccfa9..0f12823 100644
+--- a/tests/test_imapclient.py
++++ b/tests/test_imapclient.py
+@@ -604,8 +604,8 @@ def test_redacted_password(self):
+ adapter = IMAPlibLoggerAdapter(logger_mock, dict())
+ if six.PY3:
+ adapter.info("""> b'ICHH1 LOGIN foo@bar.org "secret"'""")
+- if sys.version_info >= (3, 7):
+- # LoggerAdapter in Python 3.7+ calls logger.log()
++ if sys.version_info >= (3, 6, 4):
++ # LoggerAdapter in Python 3.6.4+ calls logger.log()
+ logger_mock.log.assert_called_once_with(
+ logging.INFO,
+ "> b'ICHH1 LOGIN **REDACTED**",
diff --git a/dev-python/imapclient/imapclient-2.1.0.ebuild b/dev-python/imapclient/imapclient-2.1.0.ebuild
new file mode 100644
index 000000000000..2b5dec6af405
--- /dev/null
+++ b/dev-python/imapclient/imapclient-2.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
+HOMEPAGE="https://github.com/mjs/imapclient"
+SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
+
+PATCHES=(
+ # fix incorrect assumption about py3.6 behavior
+ # https://github.com/mjs/imapclient/pull/384
+ "${FILESDIR}"/imapclient-2.1.0-py36-tests.patch
+)
+
+python_compile_all () {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.rst NEWS.rst README.rst )
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}