summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-04 22:17:43 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-04 22:17:43 +0200
commit6c30cfb1a3781138d93c450ddf5f028f3dd0c7c3 (patch)
treec133bf300bf35f23650a873a731a4252973a27ff
parentgames-action/multimc: drop version 0.6.12 (diff)
downloadgentoo-6c30cfb1a3781138d93c450ddf5f028f3dd0c7c3.tar.gz
gentoo-6c30cfb1a3781138d93c450ddf5f028f3dd0c7c3.tar.bz2
gentoo-6c30cfb1a3781138d93c450ddf5f028f3dd0c7c3.zip
games-action/multimc-bin: add version 1.6.1
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--games-action/multimc-bin/Manifest1
-rw-r--r--games-action/multimc-bin/multimc-bin-1.6.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/games-action/multimc-bin/Manifest b/games-action/multimc-bin/Manifest
index 0e647fe50cbd..da7937bca706 100644
--- a/games-action/multimc-bin/Manifest
+++ b/games-action/multimc-bin/Manifest
@@ -1 +1,2 @@
DIST multimc_1.5-1.deb 7692 BLAKE2B c5b4de864c95cccd96b071d4d551e322eb5c78e17a8da361ee69a82405691c6d9fc81c7eef9dcf855a8e2145fbb362d31c7f63682c7a66edbc37dbf9215e7c1b SHA512 26fe11eff406efd09612002e4c53fc1ea0b3f7d0aca389475a7afff454efa52ed52097f6a0bbc27de61fba3fed252321754738a0f79b0d8a7308a39701087e67
+DIST multimc_1.6-1.deb 7672 BLAKE2B 21df885937c137d7f0c2460b10aeffefd5ea010ea4de3c73168660b7b5041fbe38a764ea62d549e52aec0183901aacdf9cf6fe580607bb05e5bd19cbf383e7f0 SHA512 0e603ae0ef1e8a3dd8e6f92a5a9d32b96b9b0901cb88e368d3c97888e2cae747808e831c1598286de42de102a06631521682bfd15078c1cae663993706ec2810
diff --git a/games-action/multimc-bin/multimc-bin-1.6.1.ebuild b/games-action/multimc-bin/multimc-bin-1.6.1.ebuild
new file mode 100644
index 000000000000..2e4e4a210532
--- /dev/null
+++ b/games-action/multimc-bin/multimc-bin-1.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
+HOMEPAGE="https://multimc.org https://github.com/MultiMC/MultiMC5"
+SRC_URI="https://files.multimc.org/downloads/multimc_$(ver_rs 2 -).deb"
+# We need -bin because of secret API keys:
+# https://github.com/MultiMC/MultiMC5/issues/4087
+# https://github.com/MultiMC/MultiMC5/issues/4113
+# https://bugs.gentoo.org/814404
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ >=virtual/jre-1.8.0
+ virtual/opengl
+ x11-libs/libXrandr
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ # Rename the .desktop file to avoid file conflict with non-bin version
+ mv "${ED}/usr/share/applications/multimc.desktop" "${ED}/usr/share/applications/multimc-bin.desktop" || die
+ # Change the name so we can differentiate from the non-bin version in app menu
+ # and remove empty options
+ sed -i \
+ -e 's/Name=MultiMC 5/Name=MultiMC Official Binary/g' \
+ -e '/Path=/d' \
+ -e '/TerminalOptions=/d' \
+ "${ED}/usr/share/applications/multimc-bin.desktop" || die
+}