summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-31 11:37:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-31 11:39:05 +0100
commit6c33d4cc1e9ca5b61d1ee2d831b004219ffcb5ff (patch)
tree363951064dc3ebe1d893698bb2eb154b9d69dbd4
parentsys-apps/smartmontools: Bump to version 7.0 (diff)
downloadgentoo-6c33d4cc1e9ca5b61d1ee2d831b004219ffcb5ff.tar.gz
gentoo-6c33d4cc1e9ca5b61d1ee2d831b004219ffcb5ff.tar.bz2
gentoo-6c33d4cc1e9ca5b61d1ee2d831b004219ffcb5ff.zip
sys-apps/smartmontools: Synced live ebuild.
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index a2e1ad35a308..46b1cf2cff3f 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
inherit autotools flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.smartmontools.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps +daemon selinux static update_drivedb"
+IUSE="caps +daemon selinux static systemd update_drivedb"
DEPEND="
caps? (
@@ -34,6 +34,7 @@ DEPEND="
RDEPEND="${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
+ systemd? ( sys-apps/systemd )
update_drivedb? (
app-crypt/gnupg
|| (
@@ -49,7 +50,6 @@ REQUIRED_USE="( caps? ( daemon ) )"
src_prepare() {
default
-
eautoreconf
}
@@ -58,14 +58,15 @@ src_configure() {
# The build installs /etc/init.d/smartd, but we clobber it
# in our src_install, so no need to manually delete it.
myeconfargs=(
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
--with-drivedbdir="${EPREFIX}/var/db/${PN}" #575292
--with-initscriptdir="${EPREFIX}/etc/init.d"
+ #--with-smartdscriptdir="${EPREFIX}/usr/share/${PN}"
$(use_with caps libcap-ng)
$(use_with selinux)
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_with systemd libsystemd)
$(use_with update_drivedb gnupg)
$(use_with update_drivedb update-smart-drivedb)
+ $(usex systemd "--with-systemdsystemunitdir=$(systemd_get_systemunitdir)" '')
)
econf "${myeconfargs[@]}"
}