summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-14 15:33:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-14 17:19:40 +0200
commit6c639c8f0a66a951d04d27b6190262d54e07e5ba (patch)
treeb9feb3887497f18312aaa987d7d79385b0055cff
parentapp-text/libetonyek: Drop 0.1.10 (r0) (diff)
downloadgentoo-6c639c8f0a66a951d04d27b6190262d54e07e5ba.tar.gz
gentoo-6c639c8f0a66a951d04d27b6190262d54e07e5ba.tar.bz2
gentoo-6c639c8f0a66a951d04d27b6190262d54e07e5ba.zip
dev-libs/libixion: Drop 0.16.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libixion/Manifest1
-rw-r--r--dev-libs/libixion/files/libixion-0.16.1-clang.patch18
-rw-r--r--dev-libs/libixion/libixion-0.16.1.ebuild63
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index aff640dd2314..5513636ebc08 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,2 +1 @@
-DIST libixion-0.16.1.tar.xz 482500 BLAKE2B 26075c819a952f48c4e136fa28b4ef5075b455dea52d51940e4fc55344e19e404d70b44222631d0b0f85280d09bb8a05955bfcbe0a228b97d72d8f00f1639248 SHA512 979c631e9536f6d2c3ae32f7892756ac8889d27c551d80eb9d519bf912bd323da4b6ecd363fe2719e74e04bc3661e5d56e03a582f68f5293ffcac59b74f4c7de
DIST libixion-0.17.0.tar.xz 499836 BLAKE2B c8c31b07ad14dd49be259686af3e39e6f5d4aeeb8680030ea7bd2697c8baa72123f2659b3087f224f956612dc444c97e6a6d331fd3deff780981bab4d5b6ad25 SHA512 0acdb2eae5250236a94b1a3344ca990058ea8db7b1e741545bcb7160f9e28d21a3c2ec336621fd590df10188a4d5feadfbb3a63f57e9bfd2cc1bffc04009ffad
diff --git a/dev-libs/libixion/files/libixion-0.16.1-clang.patch b/dev-libs/libixion/files/libixion-0.16.1-clang.patch
deleted file mode 100644
index 802d43e71592..000000000000
--- a/dev-libs/libixion/files/libixion-0.16.1-clang.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://gitlab.com/ixion/ixion/-/commit/1992b8ab9c7765b8da06b6054bb3c0ab990c62f7
-https://bugs.gentoo.org/793917
-
-From: Jory Pratt <anarchy@gentoo.org>
-Date: Wed, 2 Jun 2021 10:19:01 -0500
-Subject: [PATCH] Fix nullptr_t for clang/musl users
-
---- a/src/libixion/model_context.cpp
-+++ b/src/libixion/model_context.cpp
-@@ -17,7 +17,7 @@
-
- namespace ixion {
-
--model_context::input_cell::input_cell(nullptr_t) : type(celltype_t::empty) {}
-+model_context::input_cell::input_cell(std::nullptr_t) : type(celltype_t::empty) {}
- model_context::input_cell::input_cell(bool b) : type(celltype_t::boolean)
- {
- value.boolean = b;
diff --git a/dev-libs/libixion/libixion-0.16.1.ebuild b/dev-libs/libixion/libixion-0.16.1.ebuild
deleted file mode 100644
index 0f397c8828ef..000000000000
--- a/dev-libs/libixion/libixion-0.16.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-single-r1
-
-DESCRIPTION="General purpose formula parser & interpreter"
-HOMEPAGE="https://gitlab.com/ixion/ixion"
-
-if [[ ${PV} == *9999 ]]; then
- MDDS_SLOT="1/9999"
- EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
- inherit git-r3 autotools
-else
- MDDS_SLOT="1/1.5"
- SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/0.16" # based on SONAME of libixion.so
-IUSE="debug python +threads"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost:=
- dev-util/mdds:${MDDS_SLOT}
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-clang.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- $(use_enable debug)
- $(use_enable debug debug-utils)
- $(use_enable debug log-debug)
- $(use_enable python)
- $(use_enable threads)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}