summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-07 04:59:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-07 04:59:48 +0100
commit6c7383ea40474bb11d50a3a18febb5d3b2ab657a (patch)
tree0e34e3ad0bb4714dfd3347e2e620d7ea2971173b
parentapp-admin/awscli: Bump to 1.27.45 (diff)
downloadgentoo-6c7383ea.tar.gz
gentoo-6c7383ea.tar.bz2
gentoo-6c7383ea.zip
dev-python/jq: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jq/Manifest1
-rw-r--r--dev-python/jq/jq-1.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jq/Manifest b/dev-python/jq/Manifest
index ae0c90c1673f..252c25e96b41 100644
--- a/dev-python/jq/Manifest
+++ b/dev-python/jq/Manifest
@@ -1 +1,2 @@
DIST jq-1.3.0.gh.tar.gz 2648187 BLAKE2B 61b6d4dbb2163477d09e69c25e0bec98780f39088d4e689a7e13ed8d64749c2e238f2bf7d1f6c47f3cebe1c94a1e5fa5322a988ce251e8417aac77c789975064 SHA512 cf3c1ac7954d36d808b9f9841ff7f71835e3324f6f8eb09ef3a66b446b47a354d8ff090dc3529b9936ec5d7a33ba5163354d3534f0dfc0cb467222a990e58fb5
+DIST jq.py-1.4.0.gh.tar.gz 2648402 BLAKE2B 5efc35fd9ee52e5c1c87ac46d980d1557121eedb14beb5d534987d81a37b05c5c765ef69cecf65141d7c451623d05d378bdcf9a6e48667c07a9f52e7d0317bbf SHA512 8acd9c4094e0e6f5ffd43303432347448e8cb160f2c33250a386afc75eac53134b15142da3f344b0ea3eac4df838ffa322771580a27349299f32a2c525e09555
diff --git a/dev-python/jq/jq-1.4.0.ebuild b/dev-python/jq/jq-1.4.0.ebuild
new file mode 100644
index 000000000000..2bbe57192855
--- /dev/null
+++ b/dev-python/jq/jq-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="jq.py-${PV}"
+DESCRIPTION="Python bindings for jq"
+HOMEPAGE="
+ https://github.com/mwilliamson/jq.py/
+ https://pypi.org/project/jq/
+"
+SRC_URI="
+ https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # Cython compilation isn't part of setup.py, so do it manually
+ "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
+ distutils-r1_python_compile
+}