summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-18 15:59:15 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-18 17:00:28 +0200
commit6c83b56a60b059a91d5aad3107734cfe17b839ee (patch)
tree4ac41a3afce9f850d109a53e773769713c9b667b
parentdev-lang/dafny: add "go" test dependency (diff)
downloadgentoo-6c83b56a60b059a91d5aad3107734cfe17b839ee.tar.gz
gentoo-6c83b56a60b059a91d5aad3107734cfe17b839ee.tar.bz2
gentoo-6c83b56a60b059a91d5aad3107734cfe17b839ee.zip
dev-lang/polyml: bump to 5.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/polyml/Manifest1
-rw-r--r--dev-lang/polyml/polyml-5.9.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-lang/polyml/Manifest b/dev-lang/polyml/Manifest
index caf41184c810..be19627eb840 100644
--- a/dev-lang/polyml/Manifest
+++ b/dev-lang/polyml/Manifest
@@ -1 +1,2 @@
+DIST polyml-5.9.1.tar.gz 3887664 BLAKE2B ae10fc9c4097879fe05ab931c541cdab8a61755210e2f6b084e31a08490a762234ea32d18d9d60e3ec52407861106b1b85d0ca8a92d2bc3e97b1d14fbd57bf8e SHA512 e471abef01b7f2bfac6d847904c0fcef6ae5a1356b1246a2e8982d24fd590b49feb03752642efe09d34344b4faf89bc3edd4418e9993e72ea22e5482e6d37271
DIST polyml-5.9.tar.gz 3764115 BLAKE2B ae0ca0dcac2c1b5b54e4e4c4c7362a9ba99846ff7a1358a2332a8b887eb9c21e83851c9ecde44df3bebeef5cdfe3d4b73c09776a08cfc2db6ec70024ffedc50d SHA512 e996cbe820216e854a50ba214f2a2a0291ee3279eb35be4126b6558bc1582732a236156fb8d0f548b31fca4a496db62ece83d902b6f5e72de64507fdef602e45
diff --git a/dev-lang/polyml/polyml-5.9.1.ebuild b/dev-lang/polyml/polyml-5.9.1.ebuild
new file mode 100644
index 000000000000..2c8ed0b90e8a
--- /dev/null
+++ b/dev-lang/polyml/polyml-5.9.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Poly/ML is a full implementation of Standard ML"
+HOMEPAGE="https://www.polyml.org/
+ https://github.com/polyml/polyml/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="X +gmp portable"
+
+RDEPEND="
+ dev-libs/libffi:=
+ X? ( x11-libs/motif:0 )
+ gmp? ( >=dev-libs/gmp-5:= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.8.2-configure.patch
+ "${FILESDIR}"/${PN}-5.9-c++11.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --enable-shared
+ --with-pic=pic-only
+ $(use_enable !portable native-codegeneration)
+ $(use_with X x)
+ $(use_with gmp)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ default
+
+ if [[ -f "${ED}"/usr/$(get_libdir)/libpolymain.la ]] ; then
+ rm "${ED}"/usr/$(get_libdir)/libpolymain.la || die
+ fi
+
+ if [[ -f "${ED}"/usr/$(get_libdir)/libpolyml.la ]] ; then
+ rm "${ED}"/usr/$(get_libdir)/libpolyml.la || die
+ fi
+}