summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-12 16:49:31 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-12 16:52:08 -0500
commit6c95eb028a8c38807ccb1eb3f41046b4902550a4 (patch)
tree062b5556e9ff433055182bc8559e6d0aad4024ef
parentdev-python/django-tables2: 2.0.3 bump (diff)
downloadgentoo-6c95eb02.tar.gz
gentoo-6c95eb02.tar.bz2
gentoo-6c95eb02.zip
dev-python/django-debug-toolbar: 1.11 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 01ba026b5921..8533b8502424 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1 +1,2 @@
+DIST django-debug-toolbar-1.11.tar.gz 321727 BLAKE2B 89eab65bc0306da9fd81affbffc312eb99d04f19c66d9e5c6016df323a987e1b3fe1d177d409d68548aede869ed6d3e71adb5f4f4e5cb85a9ab431eca5664033 SHA512 8085b02fc25571e7b3bff02ff2bda8bec81a6000c6ed9e2aea10ec45eb1a3e5adf2ee95fcfbb0a11660fd716ebf2e35a9bdefbaf767b4afc732368a197857e62
DIST django-debug-toolbar-1.5.tar.gz 315928 BLAKE2B 8dde3c655baa6bd5f3b5d3ae0ba57b8c5746fc41bcfae9f506ad5c49ff64cdb51f0b9d67ee42695f884493cf21bd76fdcf943d88d97641b5d804d54c59163562 SHA512 9a421b80016bdaee8dd3ba2a9b7c3b788b54a4f464cdd5697e36536268e4d3d926bf77088a715e87f192dc8a20a100d8adac68c9c26a1191a5343e377240bf64
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild
new file mode 100644
index 000000000000..08bd4b0acde5
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-1.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}