summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-10-18 12:37:27 +0200
committerUlrich Müller <ulm@gentoo.org>2022-10-18 12:42:16 +0200
commit6c9b7e2d639e131c8d466fffa47ccb43cc866ef6 (patch)
tree4f2e3a5fad9884ca357d636be1dda9d6f8db9ccd
parentdev-libs/nspr: Stabilize 4.35 sparc, #877377 (diff)
downloadgentoo-6c9b7e2d639e131c8d466fffa47ccb43cc866ef6.tar.gz
gentoo-6c9b7e2d639e131c8d466fffa47ccb43cc866ef6.tar.bz2
gentoo-6c9b7e2d639e131c8d466fffa47ccb43cc866ef6.zip
sys-auth/pam_skey: Don't link against libnsl
EAPI 8. Don't inherit unused multilib and pam eclasses. Update HOMEPAGE and SRC_URI. Bug: https://bugs.gentoo.org/877433 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--sys-auth/pam_skey/Manifest1
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r7.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-auth/pam_skey/Manifest b/sys-auth/pam_skey/Manifest
index f851ac337e4e..8f54c46b6341 100644
--- a/sys-auth/pam_skey/Manifest
+++ b/sys-auth/pam_skey/Manifest
@@ -1,2 +1,3 @@
DIST pam_skey-1.1.5-patches-7.tar.xz 9408 BLAKE2B d87da6c4606431618a1a4d75981809cbd91a8e5e3d1f9eae6fbb222e146d451f7c099f9b437829304b647a20c6200797732e9d01451cc4911abba7843151e36c SHA512 8bb39c2d173468c38b4d2bdac186d3f27e868c2be9dc6feffba957d4d33bc8e597c48e4638e5de09829000961fbf8b72f0ba577f232bebdfaa4c2961ede58838
+DIST pam_skey-1.1.5-patches-8.tar.xz 9500 BLAKE2B 7fafa0e5c63da6a66e96266768d522cb35eeb439c45b0cf449ce6897804ca8086826a450e24e6c4eb0478b5a00f0eba02097ecd6c6e911de9c33ccb7beed20de SHA512 2d0745148496137be4ed5b03fd4dcaebb65efd24c21b2d969341d10381b8f32f0731b2880b9516de46570c1133e5573fa1a08129fe539aed7fd535d10a31b34d
DIST pam_skey-1.1.5.tar.gz 76963 BLAKE2B ded4a4e43b174338cd1beefce65314cc906db928593dd5eba2ba1be9cab33844d8fd38cb7d3b952a29da632b671c468e0dfe7f0f1e0d167397320cd9ca6d35e1 SHA512 12817cedf15a3b2287982e4beab5d3b388239cc0a1e141e66e41759ddb2da7fb9dd0df12202dcc8140db0868c8df1a8d19d5859224179e2419ffefd691cb9834
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r7.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r7.ebuild
new file mode 100644
index 000000000000..0a9ace209128
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="https://web.archive.org/web/20041223070454/http://kreator.esa.fer.hr/projects/pam_skey/"
+SRC_URI="https://dkorunic.net/tarballs/${P}.tar.gz
+ https://dev.gentoo.org/~ulm/distfiles/${P}-patches-8.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${WORKDIR}/patch")
+DOCS="README INSTALL"
+
+src_prepare() {
+ default
+
+ cd autoconf || die
+ mv configure.{in,ac} || die
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+src_install() {
+ default
+
+ local DOC_CONTENTS="To use the pam_skey module, you need to
+ configure PAM by adding a line like:
+ \n\nauth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so\n
+ \nto an appropriate place in the /etc/pam.d/system-login file.
+ Consult the README and INSTALL files in /usr/share/doc/${PF}
+ for detailed instructions.
+ \n\nPlease note that calling this module from unprivileged
+ applications, e.g. screensavers, is not supported.
+ \n\nError checking has become stricter in pam_skey-1.1.5-r4;
+ errors returned from the underlying skey library when accessing
+ the S/Key data base will no longer be ignored.
+ Make sure that your PAM configuration is correct."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}