summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 07:47:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 08:08:31 +0200
commit6c9fe078976d1b053e577ca402ecb18daa5f20f1 (patch)
tree1b1e638de7fe3ea1b2612486dfcba68d83afd12f
parentdev-embedded/platformio: unpin aiofiles, ajsonrpc (diff)
downloadgentoo-6c9fe078976d1b053e577ca402ecb18daa5f20f1.tar.gz
gentoo-6c9fe078976d1b053e577ca402ecb18daa5f20f1.tar.bz2
gentoo-6c9fe078976d1b053e577ca402ecb18daa5f20f1.zip
dev-python/cx_Freeze: Bump to 6.14.9
Closes: https://bugs.gentoo.org/893798 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.14.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index 94e9acdf9a27..d2716bb79d01 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1,2 +1,3 @@
DIST cx_Freeze-6.13.1.gh.tar.gz 1486207 BLAKE2B aa0151fed482714e41a859059f9672950249ad7fe50fa2accaa9d6af7ddc183a8f74d87337f274849a34a404dda0c732300343b58cd872f3bd03bf275c2f4d97 SHA512 48d569fdce5c6cb100232ce3577f0a55a40f3d1dcafa884a4d62af7f27200a21eb892504b47fb7cd106f410354b70d98a8e5245382431bc1f6d990510c77cb36
DIST cx_Freeze-6.14.5.gh.tar.gz 1648095 BLAKE2B 81707d17c2118a8db4d768b2fbe83278c6b01509a5a1d3e7f3a41efaa29607fc4b254e9d545a4697b77d4932100f344a8013ac59084bb74d97d1b12cb927ec6e SHA512 52233a138da3250e97668a5c225e78b864bebaa43ea2b30de01af2de7739f48a25030e10d36ccec609240822de308ad030eaa26c2ede8b29318d2b30647cf1c8
+DIST cx_Freeze-6.14.9.gh.tar.gz 1649748 BLAKE2B 08fefea6ed9610b672ca8a4a6e480cedf8fd75c967880e74f94c12368ec1ff71a9d34baae02342f7c4484e65beda5dc71dd39e13b8c340c5b7dd2e89b38ba0f1 SHA512 bfe3e5d3dcf96cff448b034a779b93c37dacda489ee4eabd92e8f4708c6d7a9fe2430bc512f40c6af8c6f851fff24a3626b80f10295af1357e4a58563474e8eb
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.14.9.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.14.9.ebuild
new file mode 100644
index 000000000000..0c7a33ecf5bd
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.14.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="
+ https://cx-freeze.readthedocs.io/
+ https://github.com/marcelotduarte/cx_Freeze/
+ https://pypi.org/project/cx-Freeze/
+"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.9)
+ dev-util/patchelf
+ virtual/libcrypt:=
+"
+BDEPEND="
+ test? (
+ app-arch/rpm
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pythonic dep on patchelf exec
+ sed -i -e '/patchelf/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # rpm test expects .pyc
+ local -x PYTHONDONTWRITEBYTECODE=
+ rm -rf cx_Freeze || die
+ epytest
+}