summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-04 14:03:50 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-04 14:00:27 -0400
commit6cae4276c0a3e93bb40012a5eb8b192b77f593d7 (patch)
tree819bd756ce0ffddf386aef5120822c13a6956833
parentapp-editors/gedit: Version bump to 43.1 (diff)
downloadgentoo-6cae4276c0a3e93bb40012a5eb8b192b77f593d7.tar.gz
gentoo-6cae4276c0a3e93bb40012a5eb8b192b77f593d7.tar.bz2
gentoo-6cae4276c0a3e93bb40012a5eb8b192b77f593d7.zip
app-editors/gedit-plugins: Version bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28118 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-editors/gedit-plugins/Manifest1
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-43.1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 79d7e09fce7d..2df23b5af3fd 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1 +1,2 @@
DIST gedit-plugins-42.1.tar.xz 946368 BLAKE2B 6ee8c42d5d5214cdb9095bce71623f9486c973ade69aad91eed4ae13a1ad5ab59bcc43d30078bdb9db46527160f8bc6b183a56c255d10f8027c4ff2e603fffa6 SHA512 2e36919f7b7232e4471e2c1277c33e2f79ff513b76574cf765e451064979587c170ae003c9517d33f3b9cfce916cb7f25f9e3d0a4f6a6b203086fcfff9f265aa
+DIST gedit-plugins-43.1.tar.xz 913072 BLAKE2B ebfaa6311aac490c75339cf506a58ce60864925ebee8284d72cc4b42634696511d7060eca1b8988d574e1b17dc0e0d32cc934da3c29421339044a220ea5e854e SHA512 2aad05ce15e148121b8e0dcf59546061e448aac09f42c28cee7dfc0b3c16965716059cf147c6391f1c439ac04241e94384bf6ff8dfaa40303dfe80d8de1e2fbc
diff --git a/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild
new file mode 100644
index 000000000000..d01deb408f2f
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-43.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}