summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-03 14:27:24 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-03 14:27:24 +0100
commit6cbe4c3ed96b51d68b37610dfc9605839736a0d7 (patch)
tree44aa6163cc965cf882a6e7b8c650b317a85939a9
parentdev-ruby/rails: Keyword 6.1.7 riscv, #878485 (diff)
downloadgentoo-6cbe4c3ed96b51d68b37610dfc9605839736a0d7.tar.gz
gentoo-6cbe4c3ed96b51d68b37610dfc9605839736a0d7.tar.bz2
gentoo-6cbe4c3ed96b51d68b37610dfc9605839736a0d7.zip
sys-fs/hfsplusutils: add -fno-strict-aliasing to avoid LTO breakage
Closes: https://bugs.gentoo.org/863902 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild (renamed from sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild
index 34c9cf508cba..efffe757f332 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
MY_P="hfsplus_${PV}"
DESCRIPTION="HFS+ Filesystem Access Utilities (a PPC filesystem)"
HOMEPAGE="http://penguinppc.org/historical/hfsplus/"
SRC_URI="http://penguinppc.org/historical/hfsplus/${MY_P}.src.tar.bz2"
+S="${WORKDIR}/hfsplus-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc ppc64 x86"
-S="${WORKDIR}/hfsplus-${PV}"
-
PATCHES=(
"${FILESDIR}"/${P}-glob.patch
"${FILESDIR}"/${P}-errno.patch
@@ -31,18 +30,20 @@ PATCHES=(
src_prepare() {
default
- # let's avoid the Makefile.cvs since isn't working for us
- mv configure.{in,ac} || die
+ # let's avoid the Makefile.cvs since it isn't working for us
eautoreconf
}
src_configure() {
- econf --disable-static
+ # brittle codebase with lots of type punning, breaks LTO (#863902)
+ append-cflags -fno-strict-aliasing
+
+ default
}
src_install() {
default
newman doc/man/hfsp.man hfsp.1
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}