summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-15 21:09:36 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 22:32:57 +0000
commit6cc33559cbb263018be861f18b66e798d7b35f14 (patch)
treeefb334bc6a4bf60d38d971f0cb5d343e4b8d55b2
parentdev-haskell/cabal: bump up to 3.2.1.0 (diff)
downloadgentoo-6cc33559.tar.gz
gentoo-6cc33559.tar.bz2
gentoo-6cc33559.zip
dev-haskell/hackage-security: bump up to 0.6.0.1
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/hackage-security/Manifest2
-rw-r--r--dev-haskell/hackage-security/files/hackage-security-0.6.0.1-disable-failing-aeson-canonical-test.patch13
-rw-r--r--dev-haskell/hackage-security/hackage-security-0.6.0.1-r1.ebuild63
-rw-r--r--dev-haskell/hackage-security/metadata.xml12
4 files changed, 82 insertions, 8 deletions
diff --git a/dev-haskell/hackage-security/Manifest b/dev-haskell/hackage-security/Manifest
index 4b7cf8c67679..b087e633d8ff 100644
--- a/dev-haskell/hackage-security/Manifest
+++ b/dev-haskell/hackage-security/Manifest
@@ -1 +1,3 @@
DIST hackage-security-0.5.3.0.tar.gz 87119 BLAKE2B 6e69b13d3ee16fbc6488e1e9d926ba07d975555e9ad80c404ccfec60ff549e7eb2d40302ace8ac5f03ed5532c031f236f8a09edc8a3f8c7d4c2bb48743f88aa1 SHA512 57af812fb3911aed6ebdbc5de733e86a2bdc7845a07246c69346c59f654e7c4ae5bf20ad753cfe71dc1d7f47ce66a37fba49b178e8e6ff74002fc8ffb72d920d
+DIST hackage-security-0.6.0.1-r1.cabal 12313 BLAKE2B 41dbb4a5b175fe49ab65dba01aa1cbd1a43fbf55fc9cd06697dc984f9a3917d3da5c9c3234e336b78372899848b0fa5adf09f0507617ed0835dfad1443eb62ab SHA512 f4a8d2adde837af18587d74cf4191bc12dec22802aaafc4cd86968d893a41bf912d3649be339503063f8c698a4b8a62888ad50e0e58d3836cc55de100ca51e30
+DIST hackage-security-0.6.0.1.tar.gz 86006 BLAKE2B 6d057da569beb4e30f91a630ec37247fd47a3467e6037ebf0c4391ff58d95d5477bea09f7d66ab6d0bbe49a445ea15d53ded884f9ea7922583a03ba7497cdd9a SHA512 b83fdda3712c58bcc4237965e40bea16b9ce08f30c0671f45967e69a2eb85488e78a41c8d12b9f339f78f30cc50770a72e9e9a46e5ddf740a20bce4ea4e96fdb
diff --git a/dev-haskell/hackage-security/files/hackage-security-0.6.0.1-disable-failing-aeson-canonical-test.patch b/dev-haskell/hackage-security/files/hackage-security-0.6.0.1-disable-failing-aeson-canonical-test.patch
new file mode 100644
index 000000000000..fd83a5113c56
--- /dev/null
+++ b/dev-haskell/hackage-security/files/hackage-security-0.6.0.1-disable-failing-aeson-canonical-test.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/TestSuite.hs b/tests/TestSuite.hs
+index 598e151..f62f1c5 100644
+--- a/tests/TestSuite.hs
++++ b/tests/TestSuite.hs
+@@ -70,7 +70,7 @@ tests = testGroup "hackage-security" [
+ testProperty "prop_roundtrip_canonical" JSON.prop_roundtrip_canonical
+ , testProperty "prop_roundtrip_pretty" JSON.prop_roundtrip_pretty
+ , testProperty "prop_canonical_pretty" JSON.prop_canonical_pretty
+- , testProperty "prop_aeson_canonical" JSON.prop_aeson_canonical
++ -- , testProperty "prop_aeson_canonical" JSON.prop_aeson_canonical
+ ]
+ ]
+
diff --git a/dev-haskell/hackage-security/hackage-security-0.6.0.1-r1.ebuild b/dev-haskell/hackage-security/hackage-security-0.6.0.1-r1.ebuild
new file mode 100644
index 000000000000..e10ab6c3c0b5
--- /dev/null
+++ b/dev-haskell/hackage-security/hackage-security-0.6.0.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+# hackport: flags: -mtl21,+use-network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage security library"
+HOMEPAGE="https://github.com/haskell/hackage-security"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/4.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10
+KEYWORDS="~amd64 ~x86"
+IUSE="+lukko"
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1.1:=[profile?] <dev-haskell/base16-bytestring-1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.3:=[profile?]
+ >=dev-haskell/cabal-1.14:=[profile?] <dev-haskell/cabal-3.6:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?] <dev-haskell/cryptohash-sha256-0.12:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?] <dev-haskell/ed25519-0.1:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ lukko? ( >=dev-haskell/lukko-0.1:=[profile?] <dev-haskell/lukko-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/aeson-1.4 <dev-haskell/aeson-1.6
+ >=dev-haskell/quickcheck-2.11 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.2 <dev-haskell/tasty-1.4
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11
+ >=dev-haskell/temporary-1.2 <dev-haskell/temporary-1.4
+ >=dev-haskell/unordered-containers-0.2.8.0 <dev-haskell/unordered-containers-0.3
+ >=dev-haskell/vector-0.12 <dev-haskell/vector-0.13 )
+"
+
+# See upstream issue #247 for more details, https://github.com/haskell/hackage-security/issues/
+PATCHES=( "${FILESDIR}/hackage-security-0.6.0.1-disable-failing-aeson-canonical-test.patch" )
+
+src_prepare() {
+ default
+
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lukko lukko) \
+ --flag=-mtl21 \
+ --flag=use-network-uri
+}
diff --git a/dev-haskell/hackage-security/metadata.xml b/dev-haskell/hackage-security/metadata.xml
index 47b37051ae7f..f2a235d996f7 100644
--- a/dev-haskell/hackage-security/metadata.xml
+++ b/dev-haskell/hackage-security/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+ <flag name="lukko">Use @lukko@ for file-locking, otherwise use @GHC.IO.Handle.Lock@</flag>
</use>
<longdescription>
The hackage security library provides both server and
@@ -22,14 +23,9 @@
facilities for author package signing.
The library has two main entry points:
- "Hackage.Security.Client" is the main entry point for
+ &quot;Hackage.Security.Client&quot; is the main entry point for
clients (the typical example being @cabal@), and
- "Hackage.Security.Server" is the main entry point for
+ &quot;Hackage.Security.Server&quot; is the main entry point for
servers (the typical example being @hackage-server@).
-
- This is a beta release.
</longdescription>
- <upstream>
- <remote-id type="github">well-typed/hackage-security</remote-id>
- </upstream>
</pkgmetadata>