summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-30 15:57:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-30 16:10:24 +0200
commit6ccef5a82c2f5c3197ba0a59358c9bdb78c841d5 (patch)
tree3e5ad6306c81162a52d1589a7e712cfbb94661fc
parentapp-metrics/collectd: add pcie_errors plugin (diff)
downloadgentoo-6ccef5a8.tar.gz
gentoo-6ccef5a8.tar.bz2
gentoo-6ccef5a8.zip
app-metrics/collectd: add check_uptime plugin
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-metrics/collectd/collectd-5.11.0.ebuild37
-rw-r--r--profiles/desc/collectd_plugins.desc1
2 files changed, 20 insertions, 18 deletions
diff --git a/app-metrics/collectd/collectd-5.11.0.ebuild b/app-metrics/collectd/collectd-5.11.0.ebuild
index 03fa1e33d416..6f5057626b3b 100644
--- a/app-metrics/collectd/collectd-5.11.0.ebuild
+++ b/app-metrics/collectd/collectd-5.11.0.ebuild
@@ -49,24 +49,25 @@ COLLECTD_IMPOSSIBLE_PLUGINS="apple_sensors amqp1 aquaero barometer
# Plugins that have been (compile) tested and can be enabled via COLLECTD_PLUGINS
COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
- buddyinfo capabilities ceph cgroups chrony conntrack contextswitch
- cpu cpufreq cpusleep csv curl curl_json curl_xml dbi df disk dns
- drbd email entropy ethstat exec fhcount filecount fscache gmond gps
- hddtemp hugepages interface ipc ipmi iptables ipvs irq java lua
- load logfile logparser log_logstash madwifi match_empty_counter
- match_hashed match_regex match_timediff match_value mbmon mcelog md
- memcachec memcached memory modbus mqtt multimeter mysql netlink
- network network nfs nginx notify_desktop notify_email notify_nagios
- ntpd numa nut olsrd onewire openldap openvpn oracle ovs_events
- ovs_stats pcie_errors perl ping postgresql powerdns procevent
- processes protocols python python redis routeros rrdcached rrdtool
- sensors serial sigrok slurm smart snmp snmp_agent statsd swap synproxy
- sysevent syslog table tail tail_csv target_notification target_replace
- target_scale target_set tcpconns teamspeak2 ted thermal threshold
- turbostat ubi unixsock uptime users uuid varnish virt vmem vserver
- wireless write_graphite write_http write_influxdb_udp write_kafka
- write_log write_mongodb write_prometheus write_redis write_sensu
- write_stackdriver write_syslog write_tsdb xencpu zfs_arc zookeeper"
+ buddyinfo capabilities ceph cgroups check_uptime chrony conntrack
+ contextswitch cpu cpufreq cpusleep csv curl curl_json curl_xml
+ dbi df disk dns drbd email entropy ethstat exec fhcount filecount
+ fscache gmond gps hddtemp hugepages interface ipc ipmi iptables
+ ipvs irq java lua load logfile logparser log_logstash madwifi
+ match_empty_counter match_hashed match_regex match_timediff
+ match_value mbmon mcelog md memcachec memcached memory modbus mqtt
+ multimeter mysql netlink network network nfs nginx notify_desktop
+ notify_email notify_nagios ntpd numa nut olsrd onewire openldap
+ openvpn oracle ovs_events ovs_stats pcie_errors perl ping postgresql
+ powerdns procevent processes protocols python python redis routeros
+ rrdcached rrdtool sensors serial sigrok slurm smart snmp snmp_agent
+ statsd swap synproxy sysevent syslog table tail tail_csv
+ target_notification target_replace target_scale target_set tcpconns
+ teamspeak2 ted thermal threshold turbostat ubi unixsock uptime users
+ uuid varnish virt vmem vserver wireless write_graphite write_http
+ write_influxdb_udp write_kafka write_log write_mongodb write_prometheus
+ write_redis write_sensu write_stackdriver write_syslog write_tsdb
+ xencpu zfs_arc zookeeper"
COLLECTD_DISABLED_PLUGINS="${COLLECTD_IMPOSSIBLE_PLUGINS}"
diff --git a/profiles/desc/collectd_plugins.desc b/profiles/desc/collectd_plugins.desc
index d9a8d76eb803..6bf21031d34d 100644
--- a/profiles/desc/collectd_plugins.desc
+++ b/profiles/desc/collectd_plugins.desc
@@ -15,6 +15,7 @@ buddyinfo - Build the buddyinfo input plugin (collects statistics from /proc/bud
capabilities - Build the capabilities input plugin (collects platform capabilities decoded from the hardware subsystems)
ceph - Build the Ceph input plugin (collects statistics from the Ceph distributed storage system)
cgroups - Build the cgroups input plugin (collects CPU accounting information for processes in a cgroup)
+check_uptime - Build a plugin to notify about uptime reset
chrony - Build the chrony input plugin (collects statistics from a chrony NTP server)
conntrack - Build the conntrack input plugin (tracks the number of entries in Linux's connection tracking table)
contextswitch - Build the contextswitch input plugin (collects the number of context switches done by the operating system)