summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-05-28 16:20:59 -0700
committerZac Medico <zmedico@gentoo.org>2019-05-28 16:28:34 -0700
commit6cf3a3869363a413a8e6541c13947880367020d1 (patch)
tree1e75115cf6a7f852c1c76816363503879e4fc077
parenttoolchain.eclass: add riscv compiler abi configuration (diff)
downloadgentoo-6cf3a386.tar.gz
gentoo-6cf3a386.tar.bz2
gentoo-6cf3a386.zip
app-emulation/skopeo: version bump to 0.1.36
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/skopeo/Manifest1
-rw-r--r--app-emulation/skopeo/skopeo-0.1.36.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/skopeo/Manifest b/app-emulation/skopeo/Manifest
index 901bd425fd71..c15524f22b35 100644
--- a/app-emulation/skopeo/Manifest
+++ b/app-emulation/skopeo/Manifest
@@ -4,3 +4,4 @@ DIST skopeo-0.1.31.tar.gz 2886364 BLAKE2B 9ef9eb4fdd722216f15e14de6702aa0dfe3331
DIST skopeo-0.1.32.tar.gz 4366298 BLAKE2B b358cb197475d693fa47cdfda738a78f70c9f59c5e3e61e55f3be21ea137640de2e9c61eb6437faca9a8f0e8dd6dda673e1cd645922a23533e6101eb326ef789 SHA512 c52eeee85aa01448c9742d4e415e3ce6f2e0ef4e26a55758202baecb573ad8e3efb94c762d4c303fb21b896998b32e19f919a7382dfd6b17df2a96d66d07267b
DIST skopeo-0.1.34.tar.gz 2859957 BLAKE2B f36062374b2afa7363a02d6410bd35bbf5ccd0599eea7eb6d68b769e9fbf492dc7843dbd184fccc742250fcd3e573e33bd5454971730bcec2151a52a32b81680 SHA512 3ba99fcbff9f46fa1a4226bfc54961cf640150e0e0ac6b3457e862ef94991fa05a7bd609cbf8c87a0424df6942653fb5492a3893fa5282242c4df6913c4312a2
DIST skopeo-0.1.35.tar.gz 2723348 BLAKE2B 74a98e43ff2b32ea29b9e57ea6ba20323660b631f4a7541aa1c720e283286809c501d655af18aa794123b3af727ca54bb41686a6b0d79b33c8f82f8642cc6176 SHA512 ec5aeb596aaf51512c049dc55353ce2d076ac30ae0fc3f9e90b8a8a9fb07ec86aafe51111d38e2d34ea5193c0a6f9e74a69536bf5b759fdedfa0c97deb211894
+DIST skopeo-0.1.36.tar.gz 2754977 BLAKE2B 4a25bf092b45084d252f8cf0c50f2389210e06bb8ee4f2939cfc93e1e66764ee340d77ca7ff0e731b55dfc42c48bc69b567e6d43d10da1119f5eeeae34aba291 SHA512 2ee51017a8d768c2a7b264f4c50d4a29d8b99e30049277bca5a5d47ff0ff09bb1c92c54f7f5230d966976b41353f7c8ffb9aa5571da2471f526ec8476cb127b2
diff --git a/app-emulation/skopeo/skopeo-0.1.36.ebuild b/app-emulation/skopeo/skopeo-0.1.36.ebuild
new file mode 100644
index 000000000000..8ccfaefb099c
--- /dev/null
+++ b/app-emulation/skopeo/skopeo-0.1.36.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/containers/skopeo
+COMMIT=41991ba
+inherit golang-vcs-snapshot bash-completion-r1
+
+DESCRIPTION="Command line utility foroperations on container images and image repositories"
+HOMEPAGE="https://github.com/containers/skopeo"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ dev-libs/libgpg-error:=
+ >=sys-fs/btrfs-progs-4.0.1
+ >=sys-fs/lvm2-2.02.145:="
+DEPEND="${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ local BUILDTAGS="containers_image_ostree_stub"
+ set -- env -u GOCACHE -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" \
+ go build -ldflags "-X main.gitCommit=${COMMIT}" \
+ -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
+ -o skopeo ./cmd/skopeo
+ echo "$@"
+ "$@" || die
+ cd docs || die
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin skopeo
+ doman docs/*.1
+ dobashcomp completions/bash/skopeo
+ insinto /etc/containers
+ newins default-policy.json policy.json
+ insinto /etc/containers/registries.d
+ doins default.yaml
+ keepdir /var/lib/atomic/sigstore
+ einstalldocs
+}