summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-29 22:50:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-29 23:48:38 +0100
commit6cf9a3d510a348f571fbc6c45b60d2dcc5189a19 (patch)
tree3da972d3edca485cd0536d45f896d300b582352b
parentsci-mathematics/why3-for-spark: require ocamlopt (diff)
downloadgentoo-6cf9a3d510a348f571fbc6c45b60d2dcc5189a19.tar.gz
gentoo-6cf9a3d510a348f571fbc6c45b60d2dcc5189a19.tar.bz2
gentoo-6cf9a3d510a348f571fbc6c45b60d2dcc5189a19.zip
dev-dotnet/gentoo-dotnet-maintainer-tools: new package; add 2.0.1 & 2.9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest3
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.0.1.ebuild59
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild59
-rw-r--r--dev-dotnet/gentoo-dotnet-maintainer-tools/metadata.xml12
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest b/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest
new file mode 100644
index 000000000000..68dcaab3e941
--- /dev/null
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/Manifest
@@ -0,0 +1,3 @@
+DIST fsharp.core.8.0.100.nupkg 2816556 BLAKE2B 6662024bfcf3cd2cb14a33bf073a6df55fac12c6691e820f5aa4a57aa222f32add0518c9c9789e7f28441b901556b677f7e77237683aa9cf91cec502a8cb61ed SHA512 855cb118dfa043642fa1c86cdd80107864ed5c5d8aa7f3997a6de1a7014b6c23076f62584ab5ff489ac2ad6f86bcd2555a3b62252f2c78cdb8d37d4ab13bd021
+DIST gentoo-dotnet-maintainer-tools-2.0.1.tar.bz2 25470 BLAKE2B 2a972ab7a01997ea3a41ace118f39996f1a232a6b7d66ff5b5c9db9763960e2d188116e289e0e8e0e045350e80e9de706e899db928a1b00d0a0b1e4c58534301 SHA512 84454ef54c1228b21fa6a34c895202dfb4509314c011503c6ce4ffca941f308383d8edbbf099ef5d182635e6bd4346f0c25e9ed9a2ba817350e0485f53a52f97
+DIST system.commandline.2.0.0-beta4.22272.1.nupkg 616636 BLAKE2B 5252560598c4cd67348520cea086c37b4151b984a61238de1984838975340247b16050113422b1765931bdfc1dee38e226789b6427e56ab7c3a36bf07d0bcc20 SHA512 979a7e66ba29e17bc5bec42e926ed15362e23ae403e498c955e09dffc4d3baa14777a06f95e25d591fc9757a0eaa18deb9e4662a1ca1663fa300f509a4a0383c
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.0.1.ebuild b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.0.1.ebuild
new file mode 100644
index 000000000000..fd91397eb419
--- /dev/null
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR="$(ver_cut 1)"
+
+DOTNET_PKG_COMPAT=8.0
+NUGETS="
+fsharp.core@8.0.100
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION="Gentoo tools for .NET packages maintenance"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Dotnet
+ https://gitlab.gentoo.org/dotnet/gentoo-dotnet-maintainer-tools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+S="${WORKDIR}/${P}/Source/v${MAJOR}"
+
+LICENSE="GPL-2+"
+SLOT="0/${MAJOR}"
+
+DOTNET_PKG_PROJECTS=(
+ gdmt-check-core/src/GdmtCheckCore/GdmtCheckCore.fsproj
+ gdmt-genpwsh/src/GdmtGenpwsh/GdmtGenpwsh.fsproj
+ gdmt-gensdk/src/GdmtGensdk/GdmtGensdk.fsproj
+ gdmt-restore/src/GdmtRestore/GdmtRestore.fsproj
+)
+DOTNET_TOOLS=( gdmt-{check-core,genpwsh,gensdk,restore} )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ dotnet-pkg_src_install
+
+ local dotnet_tool
+ for dotnet_tool in "${DOTNET_TOOLS[@]}" ; do
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/${dotnet_tool}"
+ done
+}
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild
new file mode 100644
index 000000000000..fd91397eb419
--- /dev/null
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/gentoo-dotnet-maintainer-tools-2.9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR="$(ver_cut 1)"
+
+DOTNET_PKG_COMPAT=8.0
+NUGETS="
+fsharp.core@8.0.100
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION="Gentoo tools for .NET packages maintenance"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Dotnet
+ https://gitlab.gentoo.org/dotnet/gentoo-dotnet-maintainer-tools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+S="${WORKDIR}/${P}/Source/v${MAJOR}"
+
+LICENSE="GPL-2+"
+SLOT="0/${MAJOR}"
+
+DOTNET_PKG_PROJECTS=(
+ gdmt-check-core/src/GdmtCheckCore/GdmtCheckCore.fsproj
+ gdmt-genpwsh/src/GdmtGenpwsh/GdmtGenpwsh.fsproj
+ gdmt-gensdk/src/GdmtGensdk/GdmtGensdk.fsproj
+ gdmt-restore/src/GdmtRestore/GdmtRestore.fsproj
+)
+DOTNET_TOOLS=( gdmt-{check-core,genpwsh,gensdk,restore} )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ dotnet-pkg_src_install
+
+ local dotnet_tool
+ for dotnet_tool in "${DOTNET_TOOLS[@]}" ; do
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/${dotnet_tool}"
+ done
+}
diff --git a/dev-dotnet/gentoo-dotnet-maintainer-tools/metadata.xml b/dev-dotnet/gentoo-dotnet-maintainer-tools/metadata.xml
new file mode 100644
index 000000000000..b17e27cc3869
--- /dev/null
+++ b/dev-dotnet/gentoo-dotnet-maintainer-tools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.gentoo.org/</bugs-to>
+ </upstream>
+</pkgmetadata>