summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-12 08:44:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-12 08:48:58 -0500
commit6cff054214a847b5d59601feca02721645625b38 (patch)
tree84cac173d75f64133c8452a6746bdaf501f55e65
parentkde-plasma: Drop KDE Plasma 5.15.2 (diff)
downloadgentoo-6cff0542.tar.gz
gentoo-6cff0542.tar.bz2
gentoo-6cff0542.zip
gui-libs/wlroots: 0.5.0 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.5.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 0f8c25958b3f..08184ee8b888 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -2,3 +2,4 @@ DIST wlroots-0.2.tar.gz 437638 BLAKE2B dd7ca737ba2dfc00e30c83e973616cefb77fccb79
DIST wlroots-0.3.tar.gz 473490 BLAKE2B 552bcc5d8bb847dbac5caaddeac830a4de25b4cc80abb6c8b8e610b5e40cc20ff50a145fdfb6bb5f0aa53d218400777ca7a5982c74eb01bd973109b2f8fd7938 SHA512 ccec1426e6ac86fa63f82763d123162fca5be25fb37bbb44a5de651a7764f5325ef21cbe2cf698cb315f0de4719a6bac8eb0ceeffe2111de7c9f4b59e019aaaa
DIST wlroots-0.4.1.tar.gz 480127 BLAKE2B f193860ef9e0852b053270bdaa44b491a8c65a76dc01c71690f7a006eac46e606cca95675e6dec4d65487d9b98bcabb7cd12578f028a9cb9c5cd648e47754df4 SHA512 bd8863c7f285579d81b9372f1335c10eb2d0fd7b46b7589e6b2acad53fa373f2e3b549d2c31876d87d66851af0415a12a011a05953ffe2384b718db6d95cba2e
DIST wlroots-0.4.tar.gz 480114 BLAKE2B b37a711223b23c2e49f3f77ddf84d826bd432a62ec1cacb6c1323803fe6cf885397f445fc4f7c21752d962962a1d1d93399d9b66031031e1f5a3f1bff2ff717e SHA512 49b35b3a89f640d8b5fe97543aab8de90b42a112c29ef678d38bd5ba44a3718276f3c43bf0dade07be5322eb4b90258c7d99c2432f8b6af61f3109fc6b77ad58
+DIST wlroots-0.5.0.tar.gz 481154 BLAKE2B 094c7c92191ea9c581debc90fa7b0117ed15328c11a098e53cec05b326e84c54481a69382ef9a592337ade370ffb55ea98b545794471808dee9f41ee9db8194f SHA512 4defecff91a6179d3a6b7d05c92c14b20c7fa69263a889869912e913a5d1e29f9fd4684f9816b03e2427a21c004d64236f35d8282e02e8d27d826442f1f8b3a7
diff --git a/gui-libs/wlroots/wlroots-0.5.0.ebuild b/gui-libs/wlroots/wlroots-0.5.0.ebuild
new file mode 100644
index 000000000000..9d83039a2165
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.5.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind icccm rootston systemd x11-backend X"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=dev-libs/libinput-1.7.0:0=
+ >=dev-libs/wayland-1.16.0
+ media-libs/mesa[egl,gles2,gbm]
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ elogind? ( >=sys-auth/elogind-237 )
+ icccm? ( x11-libs/xcb-util-wm )
+ systemd? ( >=sys-apps/systemd-237 )
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xorg-server[wayland]
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.17
+ virtual/pkgconfig
+"
+
+FILECAPS=( cap_sys_admin usr/bin/rootston )
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ -Dlibcap=$(usex filecaps enabled disabled)
+ -Dxcb-icccm=$(usex icccm enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
+ $(meson_use rootston)
+ "-Dexamples=false"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ if use rootston; then
+ dobin "${BUILD_DIR}"/rootston/rootston
+ newdoc rootston/rootston.ini.example rootston.ini
+ fi
+
+ meson_src_install
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+ if use rootston; then
+ elog ""
+ elog "You should copy (and decompress) the example configuration file"
+ elog "from ${EROOT:-${ROOT}}/usr/share/doc/${PF}/rootston.ini"
+ elog "to the working directory from where you launch rootston"
+ elog "(or pass the '-C path-to-config' option to rootston)."
+ if ! use systemd && ! use elogind; then
+ elog ""
+ elog "If you use ConsoleKit2, remember to launch rootston using:"
+ elog "exec ck-launch-session rootston"
+
+ fcaps_pkg_postinst
+ fi
+ fi
+}