summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-06 15:13:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-06 15:38:30 +0100
commit6d0858ec7469d1327e9fad71108a9a637469851e (patch)
tree2719c7de2b5bb45dc07a07cc1d9eab60bdfa57fc
parentdev-python/django-setuptest: Drop to ~arch (diff)
downloadgentoo-6d0858ec7469d1327e9fad71108a9a637469851e.tar.gz
gentoo-6d0858ec7469d1327e9fad71108a9a637469851e.tar.bz2
gentoo-6d0858ec7469d1327e9fad71108a9a637469851e.zip
dev-python/django: Remove vulnerable (drop to ~arch)
Bug: https://bugs.gentoo.org/692384 Bug: https://bugs.gentoo.org/701744 Bug: https://bugs.gentoo.org/706204 Bug: https://bugs.gentoo.org/707998 Bug: https://bugs.gentoo.org/711522 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django/Manifest4
-rw-r--r--dev-python/django/django-2.1.8.ebuild88
-rw-r--r--dev-python/django/django-2.1.9.ebuild88
-rw-r--r--dev-python/django/django-2.2.1.ebuild91
-rw-r--r--dev-python/django/django-2.2.2.ebuild91
5 files changed, 0 insertions, 362 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 268a20019d7d..04789f79fe57 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,5 +1 @@
-DIST Django-2.1.8.tar.gz 8613572 BLAKE2B 543e41f1b4031b624f903f075e95af7e010510f4c265aebd35a5f6b3f074703b3a4b54bc7f2a9752e717ac99d20c42d6e34e556ca619a531cf8c66622ce1419a SHA512 f84fcdf919091a9db6289f25da601ce447382f79118a99f8f316b2479a9325d629f725edb4618300f76e23bd68ae45ff4c6b6576988f109d1a7ba715c73327c3
-DIST Django-2.1.9.tar.gz 8608747 BLAKE2B d5ef1aacc30067dfe5369655eb23ea67788f22edcf8ba070944c0fb4fdf2fc3628a364d480a3d47bae0339255fb66a3bc27f11eb5f07280812ab5f57b4367c64 SHA512 1f6ad122012d898da52ce44465700d2492ef9002d5c327b25e3edfe2116b8a1143feab79751a581029664311452d52d96fe116d8817edb0ef7d7dbddfc0a5ec7
-DIST Django-2.2.1.tar.gz 8973889 BLAKE2B 890ab092807a587dbaba69fb6da7a4c53c8e976d3a4c29003549d72dd69c374640df280885a62845dda0d00f432e398747b9ed652aebbd7e3434c07e71d9a80f SHA512 661ed7352847d2167f8d3410b476cb585a269ef5d3afe0cb59cf0c9a2ea22f0572f12825368bc222f33f8c6d4c71767adade97e25b69f5a619795ccb670773e2
DIST Django-2.2.11.tar.gz 9010479 BLAKE2B 9df126f62368c43a64fcdbf9d3831c78dd37e41eb88670517eeec84043083cc437d95301d86798b5945313b515d63bd12cba8484e74b6da2311af2e86ce87adc SHA512 b33ece4606e5a23626caee121018522166a0e1f32bd41ea4eb3d4c1f624943990a07e04c5a4f5d52958e733790178474e9314d346ce1e4d5d6e49ac2a700c857
-DIST Django-2.2.2.tar.gz 8841523 BLAKE2B fc498c19caed7fc8766b015df3049ce325886ebcebf02a1f6618c13ea9d12dea56ad65b860f3b0dee0b6532d97e754bb8cca2c3f0a375c630c28d52a2fd62a2e SHA512 87e0a7b2d0e6d6149c746a7cd5547351ba002c6eaedac160e72544b429d41b133da5c36256a07155b7b4743969e9ff4c3ac890c9925db428117f68a67104df0f
diff --git a/dev-python/django/django-2.1.8.ebuild b/dev-python/django/django-2.1.8.ebuild
deleted file mode 100644
index ad94ca7e5681..000000000000
--- a/dev-python/django/django-2.1.8.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
-)
-
-python_prepare_all() {
- # Prevent d'loading in the doc build
- sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}-admin
- bashcomp_alias ${PN}-admin django-admin.py
-
- if use doc; then
- rm -fr docs/_build/html/_sources || die
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Additional Backend support can be enabled via"
- optfeature "MySQL backend support" dev-python/mysqlclient
- optfeature "PostgreSQL backend support" dev-python/psycopg:2
- echo ""
- elog "Other features can be enhanced by"
- optfeature "GEO Django" sci-libs/gdal[geos]
- optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
- optfeature "ImageField Support" dev-python/pillow
- optfeature "Password encryption" dev-python/bcrypt
- optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-}
diff --git a/dev-python/django/django-2.1.9.ebuild b/dev-python/django/django-2.1.9.ebuild
deleted file mode 100644
index 17df98e2f238..000000000000
--- a/dev-python/django/django-2.1.9.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
-)
-
-python_prepare_all() {
- # Prevent d'loading in the doc build
- sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}-admin
- bashcomp_alias ${PN}-admin django-admin.py
-
- if use doc; then
- rm -fr docs/_build/html/_sources || die
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Additional Backend support can be enabled via"
- optfeature "MySQL backend support" dev-python/mysqlclient
- optfeature "PostgreSQL backend support" dev-python/psycopg:2
- echo ""
- elog "Other features can be enhanced by"
- optfeature "GEO Django" sci-libs/gdal[geos]
- optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
- optfeature "ImageField Support" dev-python/pillow
- optfeature "Password encryption" dev-python/bcrypt
- optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-}
diff --git a/dev-python/django/django-2.2.1.ebuild b/dev-python/django/django-2.2.1.ebuild
deleted file mode 100644
index a6202a73ae12..000000000000
--- a/dev-python/django/django-2.2.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/python-sqlparse[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[webp,${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/tblib[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
-)
-
-python_prepare_all() {
- # Prevent d'loading in the doc build
- sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}-admin
- bashcomp_alias ${PN}-admin django-admin.py
-
- if use doc; then
- rm -fr docs/_build/html/_sources || die
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Additional Backend support can be enabled via"
- optfeature "MySQL backend support" dev-python/mysqlclient
- optfeature "PostgreSQL backend support" dev-python/psycopg:2
- echo ""
- elog "Other features can be enhanced by"
- optfeature "GEO Django" sci-libs/gdal[geos]
- optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
- optfeature "ImageField Support" dev-python/pillow
- optfeature "Password encryption" dev-python/bcrypt
- optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-}
diff --git a/dev-python/django/django-2.2.2.ebuild b/dev-python/django/django-2.2.2.ebuild
deleted file mode 100644
index 754fb915ddd5..000000000000
--- a/dev-python/django/django-2.2.2.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/python-sqlparse[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[webp,${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/tblib[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
-)
-
-python_prepare_all() {
- # Prevent d'loading in the doc build
- sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}-admin
- bashcomp_alias ${PN}-admin django-admin.py
-
- if use doc; then
- rm -fr docs/_build/html/_sources || die
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Additional Backend support can be enabled via"
- optfeature "MySQL backend support" dev-python/mysqlclient
- optfeature "PostgreSQL backend support" dev-python/psycopg:2
- echo ""
- elog "Other features can be enhanced by"
- optfeature "GEO Django" sci-libs/gdal[geos]
- optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
- optfeature "ImageField Support" dev-python/pillow
- optfeature "Password encryption" dev-python/bcrypt
- optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-}