summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-21 22:40:57 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-21 22:48:47 -0700
commit6d1a626cfeed06004c9c5d46d352455ed209a21f (patch)
treec13e0aad18039e66cef1e764a4dbc1e8a11b41d2
parentdev-util/hip: bump version to 5.0.2 (diff)
downloadgentoo-6d1a626c.tar.gz
gentoo-6d1a626c.tar.bz2
gentoo-6d1a626c.zip
dev-cpp/gtkmm: Version bump to 4.6.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-cpp/gtkmm/Manifest1
-rw-r--r--dev-cpp/gtkmm/gtkmm-4.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/gtkmm/Manifest b/dev-cpp/gtkmm/Manifest
index ddccaab85ef2..2d84ef1cde4d 100644
--- a/dev-cpp/gtkmm/Manifest
+++ b/dev-cpp/gtkmm/Manifest
@@ -1,3 +1,4 @@
DIST gtkmm-2.24.5.tar.xz 12022024 BLAKE2B 6b2bca9fe6ad81cd956e1f3cc3140bc503b78386cf3931c8eeac08c8b2a08c73450bdbb703d1febaee67cdf834093ff5e89790f866357190822613a68a596ad3 SHA512 c50e52830977c37181439f4b82a30ac8bead0cf9022d2bec8225f8dc33e08414f863bf67056e1938fae8f888c09a5a6d757acc011fa9331a78caa6bb626dd51e
DIST gtkmm-3.24.5.tar.xz 13540488 BLAKE2B b55c55e4bb56bc835be9c09dae59ee103fb0ae80ee99bb54c36c366686f4f1a0309435e91c2e323d7ebfabf7922b76ac85de6a1132c53ab708ba17be661d834b SHA512 8cc5aed26cc631123a5b38bc19643cf9e900beb38681b29ead9049f6b8f930f0b8ace317b8290279ab89cad85075dcb66863174082f77a2b67e4d8bd3c29de49
DIST gtkmm-4.6.0.tar.xz 13910344 BLAKE2B fd46c2e0fbda32daf472cae00591ab2cff6027dc0dfeee627ab1e3ac8d44066e702781ba452926dd808b30de260f9f6700242b0d80abd91b2b3ee5faef6eee17 SHA512 d1040be44d133cfa016efc581b79c5303806d0d441b57dcc22bd84a05c3e7934f9b7b894e71d7f4a0be332daba3dd58ef558f58070b83bf8a9de7d1027d92199
+DIST gtkmm-4.6.1.tar.xz 13911284 BLAKE2B a456d19a7a5146f6a4ba93a77a053318353f14152488703c77c5a5d8532b1caa074954af875559bea8739022e4ca2cda49ed6a424946362bf39c0acd94a3a69c SHA512 87867deb2b4b0e50841e42d5957f9030c31c4ec1178b71a884a84c3c3aca178100ceb011729559f8f8f761dbe241c3cf4d420cc16c5b5aedcdd1d78f582d006d
diff --git a/dev-cpp/gtkmm/gtkmm-4.6.1.ebuild b/dev-cpp/gtkmm/gtkmm-4.6.1.ebuild
new file mode 100644
index 000000000000..e5644c7e4ae2
--- /dev/null
+++ b/dev-cpp/gtkmm/gtkmm-4.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson python-any-r1 virtualx
+
+DESCRIPTION="C++ interface for GTK+"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="4.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.68.0:2.68[doc?]
+ >=gui-libs/gtk-4.6.0:4
+ >=dev-cpp/cairomm-1.15.4:1.16[doc?]
+ >=dev-cpp/pangomm-2.50.0:2.48[doc?]
+ >=x11-libs/gdk-pixbuf-2.35.5:2
+ >=media-libs/libepoxy-1.2
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-libs/libsigc++:3 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild-demos=false
+ $(meson_use doc build-documentation)
+ $(meson_use test build-tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}