summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-17 10:33:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-17 10:33:52 -0500
commit6d1e52c6c977b5d02e0b8a0dea80ee70b80d96ab (patch)
tree434734749b8ab5964ab618ead272dc05e2c49bdd
parentsys-kernel/gentoo-sources: Linux patch 4.9.273 (diff)
downloadgentoo-6d1e52c6.tar.gz
gentoo-6d1e52c6.tar.bz2
gentoo-6d1e52c6.zip
dev-ruby/facter: 3.14.16-r1 removal
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.16-r1.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index dd8e4c87b232..948becfca010 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,3 +1,2 @@
-DIST facter-3.14.16.tar.gz 407315 BLAKE2B f9637841bd2c1d369d262c77876f08bb248f6a98e0fcb10573c872d521473790ba6eaa8dfcd6a8f0da2becd2f10c2bc7fbfde0d3a44f6a3d38c9e5f363e27e66 SHA512 3adcb7c3ce90a9cb71486c5d86eeaf1f0794194f51faf149052333d2f55a8a8fbe1e5772ecf9a0ed53196cfe732effeb383a42a43942a7803aa8b27e23939d23
DIST facter-3.14.17.tar.gz 409415 BLAKE2B 5884d1244ee869b1e8880bb243996be5a0377adcbcc7e02ccd94a98f3a98d700ad129a457dcddcc3aeae6027fb818032331ce5690019fe7186e8deb9b022430d SHA512 109a7748d883748c516ff7262c7eb589f3c7321edc3882aad242f6fece566d1e6e81f340f3dbb3a7fed16c528ba0da8769984c394178efdd447f10de1841ff53
DIST facter-3.14.18.tar.gz 409243 BLAKE2B 6d11498ecd82910ab82ec9674fbe7cf8d87f76f47dc6bf1a25c6138d498ad0c1d47ae5b2cb67fb092892e29279ff3263e2d025ff1317e4fb428105c943ee11e3 SHA512 537696324fd1ea653019fe3febdd168f40155d120bb0f9b899711c04f8252166731ab3530e2f03c01606e3549db3726e146b00781ac6ab5383f5ba2ce1e74d3f
diff --git a/dev-ruby/facter/facter-3.14.16-r1.ebuild b/dev-ruby/facter/facter-3.14.16-r1.ebuild
deleted file mode 100644
index 663babbeabf9..000000000000
--- a/dev-ruby/facter/facter-3.14.16-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake_src_compile
-}
-
-src_test() {
- cmake_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake_src_install
- ruby-ng_src_install
-}