summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-12 14:22:17 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-16 16:46:17 +0200
commit6d2129c87f33ec635970e03034cd19ba3c12f2d2 (patch)
tree205596d8758b4ba8eb4b09118bf4b4e925a4e3ed
parentdev-java/javassist: new slot: 3.29 (diff)
downloadgentoo-6d2129c87f33ec635970e03034cd19ba3c12f2d2.tar.gz
gentoo-6d2129c87f33ec635970e03034cd19ba3c12f2d2.tar.bz2
gentoo-6d2129c87f33ec635970e03034cd19ba3c12f2d2.zip
dev-java/javassist: drop 3.29.0
Closes: https://bugs.gentoo.org/857753 Closes: https://bugs.gentoo.org/857594 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26369 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/javassist/javassist-3.29.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-java/javassist/javassist-3.29.0.ebuild b/dev-java/javassist/javassist-3.29.0.ebuild
deleted file mode 100644
index 0f29828ce5cb..000000000000
--- a/dev-java/javassist/javassist-3.29.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jboss-javassist/javassist/archive/rel_3_29_0_ga.tar.gz --slot 3 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild javassist-3.29.0.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.javassist:javassist:3.29.0-GA"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A class library for editing bytecodes in Java."
-HOMEPAGE="https://www.javassist.org"
-SRC_URI="https://github.com/jboss-javassist/javassist/archive/rel_${PV//./_}_ga.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 LGPL-2.1 MPL-1.1"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-# Tests run: 431, Failures: 6
-# Cannot solve those test failures. Using "mvn test" they all pass.
-# https://bugs.gentoo.org/856364
-RESTRICT="test"
-
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:[4.13.1,) -> >=dev-java/junit-4.13.2:4
-# test? org.hamcrest:hamcrest-all:1.3 -> !!!artifactId-not-found!!!
-
-DEPEND=">=virtual/jdk-11:*"
-
-# https://github.com/jboss-javassist/javassist/blob/rel_3_29_0_ga/pom.xml#L156-L157
-RDEPEND=">=virtual/jre-8:*"
-
-S="${WORKDIR}/${PN}-rel_${PV//./_}_ga"
-
-JAVA_NEEDS_TOOLS=1
-JAVA_SRC_DIR="src/main"
-JAVA_MAIN_CLASS="javassist.CtClass"
-
-JAVA_TEST_GENTOO_CLASSPATH="hamcrest-library-1.3,junit-4"
-JAVA_TEST_SRC_DIR="src/test"
-JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-# https://github.com/jboss-javassist/javassist/blob/rel_3_29_0_ga/pom.xml#L166-L168
-# <include>javassist/JvstTest.java</include>
-JAVA_TEST_RUN_ONLY="javassist.JvstTest"
-
-src_prepare() {
- default
- java-pkg_clean javassist.jar
- sed -e 's:\.\./\.\./::' -i src/test/javassist/JvstTest{4,Root}.java || die
-}
-
-src_test() {
- default
- einfo "Testing"
- java-pkg-simple_src_test
-}