summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-23 19:49:41 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-23 20:03:53 +0200
commit6d26f0d9c24d620395ed95971d3c7325a2e2f874 (patch)
tree7388c55af0abad5277d756c0bb89231195e7e13f
parentdev-libs/libgit2-glib: Version bump to 1.0.0.1 (diff)
downloadgentoo-6d26f0d9c24d620395ed95971d3c7325a2e2f874.tar.gz
gentoo-6d26f0d9c24d620395ed95971d3c7325a2e2f874.tar.bz2
gentoo-6d26f0d9c24d620395ed95971d3c7325a2e2f874.zip
dev-python/wtforms: add 3.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-3.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 6e3f707f4717..a3850a254177 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1 +1,2 @@
DIST WTForms-3.0.0.tar.gz 137053 BLAKE2B 518dfadf248a70fd0627a822c646e884709e295517bc187750e42296896db16dddbe95aa67bf29624147e77fc9db7deb46f3ebc3558801f7b8a5895116df1922 SHA512 dbed8706a317022be07f9568d11c7dab6021642957efab38e547b7b1b83b1ac8863a521b8fb0f5f4ec15cdc2966520a76d079a00ea88ce56f40a42b335fcfc6e
+DIST WTForms-3.0.1.tar.gz 137513 BLAKE2B 17fbb385a28baefaf3fe368b7c7dbd3d6671aaef887ee89617e60e0537ae060248442d4990e7ea926b15d4b85585a1c80ffb61c0fdad2627e5cca90799eb01d7 SHA512 a6db54a7ef9bc96b8fdf69cd65d3810fab9436ff9c056e1cfc580f5ecd0ed8837dcbb7c2adf92419cc5f74e865bb3a023e316407a87d5c5277da5d30e6836fb3
diff --git a/dev-python/wtforms/wtforms-3.0.1.ebuild b/dev-python/wtforms/wtforms-3.0.1.ebuild
new file mode 100644
index 000000000000..d8ec1d1bee74
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="https://wtforms.readthedocs.io/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest