summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-30 22:49:23 +0000
committerSam James <sam@gentoo.org>2022-06-30 22:49:40 +0000
commit6d394bba10e836b03681a3e8458896f1f454221a (patch)
tree9f3527dbcade6c95bee0791067b7a2a082e54c45
parentsci-astronomy/pyephem: needs pytest (diff)
downloadgentoo-6d394bba10e836b03681a3e8458896f1f454221a.tar.gz
gentoo-6d394bba10e836b03681a3e8458896f1f454221a.tar.bz2
gentoo-6d394bba10e836b03681a3e8458896f1f454221a.zip
dev-libs/libtasn1: disable fanalyzer
Slows down build and we don't need it. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libtasn1/libtasn1-4.18.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/libtasn1/libtasn1-4.18.0.ebuild b/dev-libs/libtasn1/libtasn1-4.18.0.ebuild
index 7138eb6e7263..f6bf3c887b59 100644
--- a/dev-libs/libtasn1/libtasn1-4.18.0.ebuild
+++ b/dev-libs/libtasn1/libtasn1-4.18.0.ebuild
@@ -34,10 +34,16 @@ src_prepare() {
}
multilib_src_configure() {
+ # -fanalyzer substantially slows down the build and isn't useful for
+ # us. It's useful for upstream as it's static analysis, but it's not
+ # useful when just getting something built.
+ export gl_cv_warn_c__fanalyzer=no
+
local myeconfargs=(
$(use_enable static-libs static)
$(multilib_native_use_enable valgrind valgrind-tests)
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}