summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-11 22:12:28 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-11 22:18:06 +0200
commit6d48fc5c6104b0b6654acad6392902f48f269375 (patch)
tree7bdfb93f1c35f88e1ca725b08f8316d5cd46b56c
parentdev-ruby/middleware: keyworded 0.1.0 for hppa, bug #802141 (diff)
downloadgentoo-6d48fc5c6104b0b6654acad6392902f48f269375.tar.gz
gentoo-6d48fc5c6104b0b6654acad6392902f48f269375.tar.bz2
gentoo-6d48fc5c6104b0b6654acad6392902f48f269375.zip
app-crypt/certbot: enable py3.10 and tests
Closes: https://bugs.gentoo.org/795537 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-crypt/certbot/certbot-1.18.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-crypt/certbot/certbot-1.18.0.ebuild b/app-crypt/certbot/certbot-1.18.0.ebuild
index bf9117a89b96..d1f283af9bb4 100644
--- a/app-crypt/certbot/certbot-1.18.0.ebuild
+++ b/app-crypt/certbot/certbot-1.18.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
@@ -34,3 +35,5 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest