summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:14:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:14:55 +0200
commit6d554df2b89c62b811bf747b45d875037c6a4f7e (patch)
tree56f8d0523f2c369aa975d51d8137d392d785d2f0
parentmedia-libs/libharu: add 2.4.2 (diff)
downloadgentoo-6d554df2b89c62b811bf747b45d875037c6a4f7e.tar.gz
gentoo-6d554df2b89c62b811bf747b45d875037c6a4f7e.tar.bz2
gentoo-6d554df2b89c62b811bf747b45d875037c6a4f7e.zip
sci-chemistry/nmrglue: add 0.9
Closes: https://bugs.gentoo.org/846230 Closes: https://bugs.gentoo.org/836861 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-chemistry/nmrglue/Manifest1
-rw-r--r--sci-chemistry/nmrglue/nmrglue-0.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/nmrglue/Manifest b/sci-chemistry/nmrglue/Manifest
index a887763be6c1..8d319fcb1e4d 100644
--- a/sci-chemistry/nmrglue/Manifest
+++ b/sci-chemistry/nmrglue/Manifest
@@ -1 +1,2 @@
DIST nmrglue-0.7.tar.gz 166596 BLAKE2B 769dbe1330a2b610393cea07edcb7c997d219038ead0330e442b491b84a51f3d1ac0dd22a9399b1af2f97fbfbf0d24316bd834d71804b4607209c5d11f24939e SHA512 4d9959d151954f38efc7ea4f93539970bc75098403b0b5575f0c4ff6c2c25c1f08e207d2dee281109ffb2bdea53f2e7beb04e251cec1f638712dfe38430c23d5
+DIST nmrglue-0.9.tar.gz 14916942 BLAKE2B febe5c25a05474242654a63617388b4e65310050d07263cf6dd173ac75579c75b8b3238d7a20fe7e535ee43fe53828fe6776f18cc781c24ac571d58a1110314c SHA512 8e20a53cf53df6fb0f0ddba1361b1ead0f03c5cdd34cc7199fb9d6727060596a1f79c5c0139dd978f6b09551216a0042e8858603ce4c9b1f4063f04e06d912e5
diff --git a/sci-chemistry/nmrglue/nmrglue-0.9.ebuild b/sci-chemistry/nmrglue/nmrglue-0.9.ebuild
new file mode 100644
index 000000000000..a5a4b69f57cf
--- /dev/null
+++ b/sci-chemistry/nmrglue/nmrglue-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for working with NMR data in Python"
+HOMEPAGE="https://nmrglue.com/"
+SRC_URI="https://github.com/jjhelmus/nmrglue/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# Requires sci-chemistry/nmrpipe from ::sci
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( app-shells/tcsh )"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source dev-python/sphinx_rtd_theme dev-python/numpydoc