summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-01-02 11:43:48 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-01-02 11:54:34 +0100
commit6d5cec8200cbe876a851e2384f2dc6a7e37a7167 (patch)
tree016f6a1df85c5a89f3ac7350e6f4e8598304b478
parentwww-apps/nextcloud: drop 23.0.11 (diff)
downloadgentoo-6d5cec82.tar.gz
gentoo-6d5cec82.tar.bz2
gentoo-6d5cec82.zip
www-apps/nextcloud: add 24.0.8, 25.0.2
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--www-apps/nextcloud/Manifest2
-rw-r--r--www-apps/nextcloud/nextcloud-24.0.8.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-25.0.2.ebuild43
3 files changed, 88 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index 13a90beac784..c97bb26c5298 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,2 +1,4 @@
DIST nextcloud-24.0.7.tar.bz2 124233139 BLAKE2B 991668bf897984da0f0034f954d0077779159acc6b27447603decc79bb79d6457f98cf8324e18f2ab3dda76cbbde63bc43d3ee2f1ff918d227c8256d8f3e8789 SHA512 77c1999b52ab87779908619ec8845887c9da32f90d9eb1e639d07c3899519235a18d973a35a8bfbfe9f896c7b7705cc91d571558700550857f741f98a85a52ef
+DIST nextcloud-24.0.8.tar.bz2 124547281 BLAKE2B 0c0be4180fcf49b91534ef50b984df7eddcd275209cf3ec831aec2d4a5d8dd1ae84ed4b12db5564625066e09c109b9b4f25cb87bf6d4e32b1c54c2614fc5d556 SHA512 a885a93ac9f0fff1249ef9cbd3c88fb11786a178fcd0c4a5886c781d8270302b259267be760c6df91aa3cf27d360e38e5602fd3a186a918e50ccd55561e8f801
DIST nextcloud-25.0.1.tar.bz2 146695370 BLAKE2B 01d9482301fa50e2b938cbe164310d0e3db3a791944e78ef2d7016ecd3e214907d53b589abc51c550263e636c114ee37dd027ebf3d164493c53775a10f102a61 SHA512 7fd401ffe01e5b1d568e4f66cdc5972d5e3c0b82f147a04330da9fe5ab1f2ddf152943e28f152fb635e8bca8d83a95a5a269a1f34fa189cef4a3c9dbe4e8c89b
+DIST nextcloud-25.0.2.tar.bz2 149894878 BLAKE2B 8980fa45dcfa1f9cc70434f0bdd15154a2ef42b80bb4e57b5cb2792afa9ad77867640bc6a6d266b88e52a12aae829d34bd55d5c46fd2ba74acde0bea7b4c028e SHA512 e65147825cce7c645f552c683426b96c802c513eabbf90122e713fb5a5d341f816b0928b2af72876fdcd245b49b72bfd60f0fafb793deace3a686e13eca918bb
diff --git a/www-apps/nextcloud/nextcloud-24.0.8.ebuild b/www-apps/nextcloud/nextcloud-24.0.8.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-24.0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-25.0.2.ebuild b/www-apps/nextcloud/nextcloud-25.0.2.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-25.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}