summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-11-25 00:34:11 -0600
committerSam James <sam@gentoo.org>2023-11-29 06:20:04 +0000
commit6d7584b903c00961ba89b927781a0d2ef38ab282 (patch)
treeae1171c1ac3fd483dca0e396b904d2c32fb98a39
parentgui-libs/wlroots: bump minimum version of libdrm (diff)
downloadgentoo-6d7584b903c00961ba89b927781a0d2ef38ab282.tar.gz
gentoo-6d7584b903c00961ba89b927781a0d2ef38ab282.tar.bz2
gentoo-6d7584b903c00961ba89b927781a0d2ef38ab282.zip
gui-wm/dwl: sync live ebuilds
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild4
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild8
2 files changed, 6 insertions, 6 deletions
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
index f5f75f545d8a..ae7d26950f39 100644
--- a/gui-wm/dwl/dwl-9999-r1.ebuild
+++ b/gui-wm/dwl/dwl-9999-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/16"
+WLROOTS_SLOT="0/18"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/djpohly/dwl"
inherit git-r3
@@ -70,7 +70,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
- dodoc README.md
+ dodoc CHANGELOG.md README.md
save_config config.h
}
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
index ecba79640cf5..1bd355e65ad2 100644
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/16"
+WLROOTS_SLOT="0/17"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/djpohly/dwl"
inherit git-r3
@@ -38,7 +38,7 @@ IUSE="X"
RDEPEND="
dev-libs/libinput:=
dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[libinput(+),X?]
+ gui-libs/wlroots:${WLROOTS_SLOT}[libinput,session,X?]
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=
@@ -52,7 +52,7 @@ DEPEND="
sys-kernel/linux-headers
"
BDEPEND="
- dev-libs/wayland-protocols
+ >=dev-libs/wayland-protocols-1.32
dev-util/wayland-scanner
virtual/pkgconfig
"
@@ -70,7 +70,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
- dodoc README.md
+ dodoc CHANGELOG.md README.md
save_config config.h
}