summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-23 19:25:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 22:54:37 +0200
commit6d8e71e3effb7640e05c43914fad0ca8378806f0 (patch)
tree20a84abd6752b456ed0c892ab93a0b40d5cc7051
parentdev-games/simgear: Fix build with >=boost-1.69 (diff)
downloadgentoo-6d8e71e3.tar.gz
gentoo-6d8e71e3.tar.bz2
gentoo-6d8e71e3.zip
dev-util/ftjam: EAPI=7 bump
Closes: https://bugs.gentoo.org/686616 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12091 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/ftjam/ftjam-2.5.3_rc2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/ftjam/ftjam-2.5.3_rc2-r2.ebuild b/dev-util/ftjam/ftjam-2.5.3_rc2-r2.ebuild
new file mode 100644
index 000000000000..f8cfcd0508c4
--- /dev/null
+++ b/dev-util/ftjam/ftjam-2.5.3_rc2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV=$(ver_rs 3 "")
+
+DESCRIPTION="A 100% compatible, enhanced implementation of the make alternative Jam"
+HOMEPAGE="http://freetype.sourceforge.net/jam/index.html"
+SRC_URI="http://david.freetype.org/jam/ftjam-${MY_PV}.tar.bz2"
+
+LICENSE="perforce GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="sys-devel/bison"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DOCS=( README README.ORG CHANGES RELNOTES )
+HTML_DOCS=( Jam.html Jambase.html Jamfile.html )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.3-nostrip.patch
+ "${FILESDIR}"/${PN}-2.5.3-i-hate-yacc.patch
+ "${FILESDIR}"/${PN}-2.5.3-false-flags.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}