summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-11 23:57:52 +0100
committerSam James <sam@gentoo.org>2023-06-12 20:10:42 +0100
commit6d96da86faf72ced61b89d64ea7c6162d3c5e628 (patch)
treebfe67bc1784604bc0e0e6645cce5658d75ed94af
parentapp-doc/phrack-all: microoptimize (diff)
downloadgentoo-6d96da86faf72ced61b89d64ea7c6162d3c5e628.tar.gz
gentoo-6d96da86faf72ced61b89d64ea7c6162d3c5e628.tar.bz2
gentoo-6d96da86faf72ced61b89d64ea7c6162d3c5e628.zip
net-nds/openldap: microoptimize
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-nds/openldap/openldap-2.5.14.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.6.4-r1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-nds/openldap/openldap-2.5.14.ebuild b/net-nds/openldap/openldap-2.5.14.ebuild
index 8b5c4628b810..7a4195c78e9a 100644
--- a/net-nds/openldap/openldap-2.5.14.ebuild
+++ b/net-nds/openldap/openldap-2.5.14.ebuild
@@ -342,7 +342,7 @@ src_prepare() {
# Fish out MDB_VERSION_MAJOR/MDB_VERSION_MINOR/MDB_VERSION_PATCH from
# the bundled lmdb's header to find out the version.
local bundled_lmdb_version=$(sed -En '/^#define MDB_VERSION_(MAJOR|MINOR|PATCH)(\s+)?/{s/[^0-9.]//gp}' libraries/liblmdb/lmdb.h || die)
- bundled_lmdb_version=$(printf "%s." ${bundled_lmdb_version})
+ printf -v bundled_lmdb_version "%s." ${bundled_lmdb_version}
if [[ ${SYSTEM_LMDB_VER}. != ${bundled_lmdb_version} ]] ; then
eerror "Source lmdb version: ${bundled_lmdb_version}"
diff --git a/net-nds/openldap/openldap-2.6.4-r1.ebuild b/net-nds/openldap/openldap-2.6.4-r1.ebuild
index 2747bc015832..15efe59d9ec6 100644
--- a/net-nds/openldap/openldap-2.6.4-r1.ebuild
+++ b/net-nds/openldap/openldap-2.6.4-r1.ebuild
@@ -343,7 +343,7 @@ src_prepare() {
# Fish out MDB_VERSION_MAJOR/MDB_VERSION_MINOR/MDB_VERSION_PATCH from
# the bundled lmdb's header to find out the version.
local bundled_lmdb_version=$(sed -En '/^#define MDB_VERSION_(MAJOR|MINOR|PATCH)(\s+)?/{s/[^0-9.]//gp}' libraries/liblmdb/lmdb.h || die)
- bundled_lmdb_version=$(printf "%s." ${bundled_lmdb_version})
+ printf -v bundled_lmdb_version "%s." ${bundled_lmdb_version}
if [[ ${SYSTEM_LMDB_VER}. != ${bundled_lmdb_version} ]] ; then
eerror "Source lmdb version: ${bundled_lmdb_version}"