summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 13:48:18 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 13:59:13 +0100
commit6dc1c2f10d925843b54f4c03b921384dd9b8977a (patch)
tree3338d46444a7bdb49ccabc349c7f4ab9bbac0b4c
parentgnome-extra/gnome-clocks: Bump to 41.0 (diff)
downloadgentoo-6dc1c2f1.tar.gz
gentoo-6dc1c2f1.tar.bz2
gentoo-6dc1c2f1.zip
sci-geosciences/gnome-maps: Bump to 41.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-41.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 66d7c9b9b5d9..5ac31419a283 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,4 @@
DIST gnome-maps-40.2.tar.xz 3542008 BLAKE2B 65f23bf61e2e3c24afa80b74400dd929510c91ec463aa7e36759b1ddc60814538e21d883df37b98b5d4da851705e5f8e78e9d54a8b50a9cfd490a3e965f34b87 SHA512 6214ebeb8f5dc5fb28e0aab659a2b9f56d6b0c7b9248cd3482a268a6694ca04c75d91686a7029ec96904efcfca91a028d66d17b6311efa7e95b76379c68f6a0e
DIST gnome-maps-40.3.tar.xz 3542308 BLAKE2B cc1430a9b66ee638fb64d0bf907a8472833137cbedd19f264bf2933618af493fc4a1ece0fd9fa2edb70ab50e24a434b4775d8c81eb830958014559e2a454e0b6 SHA512 2372a3e12eb17ec9f33521fecf7f74d1edb217dd8ff6f7565485ccd8d55ff535f7eff475284a402acb9da6781b389186bcd5e4df919340374be3b244f4100077
DIST gnome-maps-40.5.tar.xz 3542648 BLAKE2B bbc45882e314667def29b8d7491afba2e1649ef62a6898a58b4afd93bd26537af73588d9cecd0ed06fc53c8083ade6d33f468b4a51481886d30abdc13558be80 SHA512 1d53dda1b96fb5a6db4152380f9136f2e66cbc0062434254cc0b47e999c19dfcbde6bc1d6bc787474eab83b29293a1e207cf41b177f7cd01b29ccb15a6628d15
+DIST gnome-maps-41.1.tar.xz 2187384 BLAKE2B 792ada987c513118411233b477373db015e55b5c4da2405d40f69833fbce3d0fdfec4c194fdfa762d5642039c4965db9a606d6206e8c52b16a4f7c26ae9b54ab SHA512 ff750c009c0409bdf87a08b2a89296f5f214f8fa294c7470e99841fc6f155ae14cf9bfd388a65231e03c4c4fdbe5606c90b2bf5897e756a1699a19782f89a5db
diff --git a/sci-geosciences/gnome-maps/gnome-maps-41.1.ebuild b/sci-geosciences/gnome-maps/gnome-maps-41.1.ebuild
new file mode 100644
index 000000000000..5ec15782805f
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-41.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.66.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libhandy-0.84:1=
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10:=
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}