summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 12:42:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 14:18:18 +0100
commit6dd97add6314d4820ea0be9ec72ca32f98ef94a3 (patch)
treea4825dd7632ceaa18370ebaddd3f437d09999c41
parentdev-python/django: Bump to 3.2.17 (diff)
downloadgentoo-6dd97add.tar.gz
gentoo-6dd97add.tar.bz2
gentoo-6dd97add.zip
dev-python/openapi-spec-validator: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openapi-spec-validator/Manifest1
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.5.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index e5cf8f2f9b97..b575645e8589 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,3 +1,4 @@
DIST openapi-spec-validator-0.4.0.gh.tar.gz 46051 BLAKE2B 43a1458ab1801700261f750e49d45b0cb4d02f1c17a16943b5232836061e0e1466fc973343bbd4bf7a8669b682bd6761cb905fdfb3b80c0b9720253cc2d5a926 SHA512 d2eaf22c75e72eb5061a916eb37b13179a5ba65eb8a00ec42e81c6b4168239bc8613388f2d77ce35113d260385b175280d8863a3deedf18ea5aa93a79f058419
DIST openapi-spec-validator-0.5.1.gh.tar.gz 39539 BLAKE2B 66adbed2c85527f89e510d5cbc11ccf05f23546191e2677a1c34f7545d2e975dda37f1c53e988e37cf526663053ac0176567137273e3be9156b24deda89db6c1 SHA512 b70a2f926d889fec9d4fd26c51e1fbbeb5e75f13449d2d0205b1b7edb12ab2ba49e4cac69426f782ca3a4430c79a6de8f66b4aad2fc552bcfcf7005e866522ff
DIST openapi-spec-validator-0.5.2.gh.tar.gz 39743 BLAKE2B 92a4c4503add68c2683f4229f7b68b7cf98d38f36f3c03835b03be5e2a1092ebbb46a9f8d09bfb9e3cf7059a2a72ff01b81742986d479c2713dc6ef783718e00 SHA512 68f7d507a239c555575e2edb3bab576fd1fede9bcebde48c57361e3e764c9c19c4dc0d63e650851c2f6e7f2dd7f4efcdcd028842e259aa9e341823cd052a6e20
+DIST openapi-spec-validator-0.5.3.gh.tar.gz 57006 BLAKE2B 0b92de74c3615789de5bb78340f75b5833172020aa8da987dd129ad24a339e93851d7830f9eb0be192af5cd35120bd5ec9601140e6edc964d5577950ac968bf5 SHA512 ef197f7bd05bcc7523a5b8992b602d5a7ea8c9cabe2166889d41ad764d2f96d7a90cbc11c247d7c33a33747cb2e6667bcbd279260d1bfc394769ef5fd1c19b25
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.3.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.3.ebuild
new file mode 100644
index 000000000000..5951fb69acfe
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-spec-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}