summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-09 21:42:35 +0100
committerSam James <sam@gentoo.org>2024-05-09 21:42:35 +0100
commit6de601b1fe5ad1a36a1c0cf52b93047b7f0b6459 (patch)
tree94080ecfff0e9bbcd2afb57804b4a2d3b99594df
parentdev-libs/igraph: update LICENSE (diff)
downloadgentoo-6de601b1fe5ad1a36a1c0cf52b93047b7f0b6459.tar.gz
gentoo-6de601b1fe5ad1a36a1c0cf52b93047b7f0b6459.tar.bz2
gentoo-6de601b1fe5ad1a36a1c0cf52b93047b7f0b6459.zip
dev-libs/igraph: add 0.10.12
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/igraph-0.10.12.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 51f9f26da78d..4c0c33ccd640 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,3 +1,4 @@
DIST igraph-0.10.10.tar.gz 4336247 BLAKE2B cef87afe544d09446c999894c44e1d56120cac74b6af5d749835fbf60e5ae0f1676d6754e084f167d23718c6ce9f7b8cee159d3d670d1d5f1f495775c7b0d2f0 SHA512 d4b8d29f9c39f8390c442877183e64c442fccbc6a02b3aed5c1d8871ca5998d1a168f392f8dde26a8c3593ed6c09a66a200ac1155fbde87d368b101011bb122c
DIST igraph-0.10.11.tar.gz 4349830 BLAKE2B 3aae088115148d1f965a52f01c950000097520fb0a150d2ad1fabb96cff434a9b548a6c17a10b9e0ebad3a577c2423ac5260cd28223147d3dc71b0d4fe139a95 SHA512 d6978589f12ed20b87777394b46f47b4ffc045ef693e5b4fc90163b9482361b2bf0ed2bb04aa99bf4a0653f7e4355cd480b0a165213d90ff7188ef6c86147c86
+DIST igraph-0.10.12.tar.gz 4373463 BLAKE2B b7fdd7046185bf501c9302721f6606e6affc0d91c16d195c6bd69e0b32f9dca7af701a963fd4a8b8558ac843fe4a5136c7fce2fe5595db469818e514db2325ac SHA512 1a7b055ab2148fdf04187d785895b930ae2a54ae0240ea9656e129a38347b1caeb28dda5a3a7e34282462363150d7afd25acf8cd335577ed441b8a5cecc0dd25
DIST igraph-0.10.4.tar.gz 4279321 BLAKE2B 4e1fc8e8d6dd38cdb24ec564f51f2924e457376c258497b51d7dd4cec88d2226d5b202cdcfa69560e43fdb3cbd49656511178acd2ed705b4af26b1947a92f1ab SHA512 71bcec5f0ba100aae7614753f9232a4221580b822b4dc120e3a80eab59d70c42aedddb00728eb13faf7e522332c514c2e030314c416ded8a70e5de990ea8039b
diff --git a/dev-libs/igraph/igraph-0.10.12.ebuild b/dev-libs/igraph/igraph-0.10.12.ebuild
new file mode 100644
index 000000000000..30a8f524a0b5
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.10.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="https://igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-mathematics/glpk:=
+ sci-mathematics/plfit
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_USE_INTERNAL_PLFIT=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DIGRAPH_WARNINGS_AS_ERRORS=OFF
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}