summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-03 00:09:19 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-04 21:00:25 +0200
commit6e03d87b5b6a87cc763ad9aa6b1bb9979f0a8d1b (patch)
tree76f05f897dcb13977cf8ed6799c0eb492792c918
parentdev-python/visitor: add Python 3.8 and 3.9 support (diff)
downloadgentoo-6e03d87b.tar.gz
gentoo-6e03d87b.tar.bz2
gentoo-6e03d87b.zip
dev-python/flask-debug: add Python 3.8 and 3.9 support
Also switch to distutils_enable_* functions. Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild b/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..9fad701cf388
--- /dev/null
+++ b/dev-python/flask-debug/flask-debug-0.4.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Debug"
+DESCRIPTION="Flask extension that displays various debugging insights during development"
+HOMEPAGE="https://github.com/mbr/Flask-Debug"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/Flask-Debug/pull/2
+SRC_URI="https://github.com/mbr/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster