summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-29 21:10:31 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-29 23:19:26 -0400
commit6e09a6d241f9a10637563dcc7fc9ac5ddcf4e9a5 (patch)
tree06ead4aa8b16ad5138a96eee1ae603b0d5a711e8
parentnet-libs/libmbim: Version bump to 1.24.6 (diff)
downloadgentoo-6e09a6d2.tar.gz
gentoo-6e09a6d2.tar.bz2
gentoo-6e09a6d2.zip
net-libs/libqmi: Version bump to 1.28.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libqmi/Manifest1
-rw-r--r--net-libs/libqmi/libqmi-1.28.2.ebuild50
-rw-r--r--net-libs/libqmi/libqmi-9999.ebuild11
3 files changed, 58 insertions, 4 deletions
diff --git a/net-libs/libqmi/Manifest b/net-libs/libqmi/Manifest
index 71a6d1d0cdce..d8c2d75181a5 100644
--- a/net-libs/libqmi/Manifest
+++ b/net-libs/libqmi/Manifest
@@ -1,2 +1,3 @@
DIST libqmi-1.22.2.tar.xz 947124 BLAKE2B 662cf58cb3fe48b5bbe167ac552b12ecff2944d1098e47b5a8c216a65c42c5e5c462f16625c4572e0e27e69a55cdfad76777468a42f8887f5b3984313c70747b SHA512 5785b56a60db8fb2566b6a712a18ec2ae74ce1da257473ab6b7cdea3163298ebee6c60a3158a7041aa759bd717eee4b16d9eeaa6b15d9b6e911bc8c8c44bd3d8
DIST libqmi-1.26.6.tar.xz 1127552 BLAKE2B 1dba56c867c688c991fde7bb019234a05d77092f0725498d677a7ff620c56e58e17c873c773d96ee2131bfeac8cdbec86dadacd8fcc2f751f4e9a8d2c75efe5b SHA512 6c5e05fc158a085e1f652ff31cef65762c026cb09eb630153fddccb15e19187141e74c79818ebe00a058c5624891981cfce4d56545d4150ebb3b6e8d7bddb5ba
+DIST libqmi-1.28.2.tar.xz 1165204 BLAKE2B 17f7462d84b74099a5ef4fa6f28e777a4587be0a7652b38c4ab5c0f50bbbbd0b8b293df22d7a8c470444df23fd405e3b176e8c449019787c5305fef13d0b27b2 SHA512 10d11b780aa381e93669aad2540c609bcd3f789302ed76d80b9845a24f84d8741b8c39287a2007ec80d8e0e517686023d08a7a677426c77f3b12ec172edc05e7
diff --git a/net-libs/libqmi/libqmi-1.28.2.ebuild b/net-libs/libqmi/libqmi-1.28.2.ebuild
new file mode 100644
index 000000000000..7ee194258147
--- /dev/null
+++ b/net-libs/libqmi/libqmi-1.28.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mobile-broadband/libqmi.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+ SRC_URI="https://www.freedesktop.org/software/libqmi/${P}.tar.xz"
+fi
+
+DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libqmi/ https://gitlab.freedesktop.org/mobile-broadband/libqmi"
+
+LICENSE="LGPL-2"
+SLOT="0/5.7" # soname of libqmi-glib.so
+IUSE="gtk-doc +mbim"
+
+RDEPEND=">=dev-libs/glib-2.48
+ dev-libs/libgudev
+ mbim? ( >=net-libs/libmbim-1.18.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )"
+[[ ${PV} == "9999" ]] && BDEPEND+=" dev-util/gtk-doc" #469214
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-Werror
+ --disable-static
+ --disable-qrtr # libqrtr-glib not packaged
+ $(use_enable mbim mbim-qmux)
+ $(use_enable gtk-doc)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/net-libs/libqmi/libqmi-9999.ebuild b/net-libs/libqmi/libqmi-9999.ebuild
index 51ac0339e070..4ee5113fe658 100644
--- a/net-libs/libqmi/libqmi-9999.ebuild
+++ b/net-libs/libqmi/libqmi-9999.ebuild
@@ -34,11 +34,14 @@ src_prepare() {
}
src_configure() {
- econf \
- --disable-Werror \
- --disable-static \
- $(use_enable mbim mbim-qmux) \
+ local myconf=(
+ --disable-Werror
+ --disable-static
+ --disable-qrtr # libqrtr-glib not packaged
+ $(use_enable mbim mbim-qmux)
$(use_enable {,gtk-}doc)
+ )
+ econf "${myconf[@]}"
}
src_install() {