summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-28 21:49:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-28 21:49:36 +0300
commit6e1d935057532cd38822b2c4b61dace500256bb7 (patch)
treede08f61aa879d32136a4df6a4c4077bd97eeb523
parentdev-python/google-api-python-client: add 2.52.0 (diff)
downloadgentoo-6e1d9350.tar.gz
gentoo-6e1d9350.tar.bz2
gentoo-6e1d9350.zip
dev-python/pycares: add 4.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-4.2.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 0f234db35a7c..50e8ddd570ee 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,2 +1,3 @@
DIST pycares-4.1.2.tar.gz 43668 BLAKE2B 4b26f8643ff5ce297981b0b60b3afb34b249138e8f702dd4aa0a38935e9e5338d048f3be1b4fb64d6d8b2259a279a8881dbd44b412c10427dbd7eee664e70495 SHA512 6fb2d24fb5f2638c55424608b02ebe9f630866d644decfb663ab9d8e2bb7a42629748fa220054747f9c36ce3dcb42f3b8e457c5c39009f94b564ff07efde0c84
DIST pycares-4.2.0.gh.tar.gz 43939 BLAKE2B 6cac12ff2b3c44cf7d04b4ce3067d5435d416788e89251d87825e5ea265ecb178948e0187c47e8dfe40ec0480a66b8b2f6cc2c45e74473e9d66f5cc74269f50f SHA512 14c813242ff6cdc5249ae52c2b9ff1870d7b74c7c6083868b2b4bbe0ce2af3f15e9b2775f67940ffbfc4ce84a6a9232ba4fab5a17ef389f7a197a15318280e43
+DIST pycares-4.2.1.gh.tar.gz 43939 BLAKE2B 40f147189d5daf841a8165da86d881f1822763fbd050b040f11bd1f63a768dfbc71c78230d41331486cbc2354175b528f298dbb167ef7801e57b05b4a13c820d SHA512 b5462b58bf75a9ee39496209c8270bc9c07070d34d9c2f2a2eed4752ebf83392e256248dda06ec5934c235cb37636e55a21cff4181b0a03c3eff24fbf9297eb4
diff --git a/dev-python/pycares/pycares-4.2.1.ebuild b/dev-python/pycares/pycares-4.2.1.ebuild
new file mode 100644
index 000000000000..aa636a8ce629
--- /dev/null
+++ b/dev-python/pycares/pycares-4.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+SRC_URI="
+ https://github.com/saghul/pycares/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/pycares-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+export PYCARES_USE_SYSTEM_LIB=1
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die "Tests failed with ${EPYTHON}"
+}