summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-03-11 09:58:51 -0600
committerMatthias Maier <tamiko@gentoo.org>2022-03-11 10:00:51 -0600
commit6e209f47ada09864211db37ff136ce2f35c5d73f (patch)
tree30464293fe539fc74ccdb5ddf33d9df14b042e43
parentnet-misc/memcached: readd ssl support (diff)
downloadgentoo-6e209f47ada09864211db37ff136ce2f35c5d73f.tar.gz
gentoo-6e209f47ada09864211db37ff136ce2f35c5d73f.tar.bz2
gentoo-6e209f47ada09864211db37ff136ce2f35c5d73f.zip
sci-libs/gmsh: add 4.9.5, drop 4.8.4
- bump to EAPI=8 - add missing python versions - port to cmake eclass Closes: https://bugs.gentoo.org/832253 Closes: https://bugs.gentoo.org/811960 Bug: https://bugs.gentoo.org/801295 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/gmsh/Manifest2
-rw-r--r--sci-libs/gmsh/gmsh-4.9.5.ebuild (renamed from sci-libs/gmsh/gmsh-4.8.4.ebuild)13
2 files changed, 7 insertions, 8 deletions
diff --git a/sci-libs/gmsh/Manifest b/sci-libs/gmsh/Manifest
index d9e4bc7d1c18..1acc490e0367 100644
--- a/sci-libs/gmsh/Manifest
+++ b/sci-libs/gmsh/Manifest
@@ -1 +1 @@
-DIST gmsh-4.8.4-source.tgz 13838352 BLAKE2B 26c7f68e41d1c339c7d5fd499b2261c2ce79c38648df9f4f3853ba69421d59be36992d8aac1d1ebc1fe872bb828769693c12fd9770878fa3b59c179176105ea4 SHA512 c3880e67af03aa6d00300b5f56fd229ffe37da9af66e8c7c87a3bbf7abcb3a90b4858ec76093ef8f039a70d4da1d5cc7f7c687c05b6642299c95e1a07f9513bf
+DIST gmsh-4.9.5-source.tgz 14921704 BLAKE2B e805bd786154bf6ce8bebb2d2c38204a88d06a251c45fbe6dd37641a15e02291993c244f26a01faad2a6445a4852274e5481d4236b7a3d9b7ee65fc863f1b880 SHA512 4da61bdf03fb9466af80ac790e83c8888bab755c78d860d601474d7ebca220ac51cba620db310165021412dbecc1cf187ccdff47b8a78e0579339bb72cfa6484
diff --git a/sci-libs/gmsh/gmsh-4.8.4.ebuild b/sci-libs/gmsh/gmsh-4.9.5.ebuild
index 61d241a9af3a..7bfa0752988d 100644
--- a/sci-libs/gmsh/gmsh-4.8.4.ebuild
+++ b/sci-libs/gmsh/gmsh-4.9.5.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
-inherit cmake-utils flag-o-matic fortran-2 python-any-r1 toolchain-funcs
+inherit cmake fortran-2 python-any-r1 toolchain-funcs
DESCRIPTION="A three-dimensional finite element mesh generator"
HOMEPAGE="http://www.geuz.org/gmsh/"
@@ -41,7 +41,6 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}-source
PATCHES=(
- "${FILESDIR}"/${P}-gcc11.patch
)
pkg_setup() {
@@ -54,7 +53,7 @@ src_configure() {
use blas && \
mycmakeargs+=(-DCMAKE_Fortran_COMPILER=$(tc-getF77))
- mycmakeargs+=(
+ local mycmakeargs+=(
-DENABLE_BLAS_LAPACK="$(usex blas)"
-DENABLE_BUILD_DYNAMIC="$(usex shared)"
-DENABLE_CGNS="$(usex cgns)"
@@ -68,11 +67,11 @@ src_configure() {
-DENABLE_PETSC="$(usex petsc)"
-DENABLE_WRAP_PYTHON="$(usex python)")
- cmake-utils_src_configure mycmakeargs
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples ; then
dodoc -r demos tutorial