summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-15 15:58:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-15 16:26:47 +0100
commit6e40843bea66c716aece27c788c28adaa03e9507 (patch)
tree8c528f95e1fda2572d21291d6cf36205a419d02f
parentxfce-base/xfce4-meta: Bump to 4.18 (diff)
downloadgentoo-6e40843bea66c716aece27c788c28adaa03e9507.tar.gz
gentoo-6e40843bea66c716aece27c788c28adaa03e9507.tar.bz2
gentoo-6e40843bea66c716aece27c788c28adaa03e9507.zip
games-emulation/ppsspp: bump to 1.14
Closes: https://bugs.gentoo.org/877509 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.14.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index e57436dd0bbb..a18b897711a7 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -25,3 +25,4 @@ DIST ppsspp-1.13.2-ext_native_tools_prebuilt.tar.gz 897571 BLAKE2B b1c959a0cd1c6
DIST ppsspp-1.13.2-ext_rapidjson.tar.gz 1054419 BLAKE2B 40b8ba0884943de2179b21d7a56716efed2ec5b4098aa33c061e52703b0952930fe2f1bda8cb6ec4a75b947753011e9d06fda953a3862e321d2a0187cd60385d SHA512 3472e129e710bf5343b8b27a61581a1480c8096493e466440b62702d8b5353745d561931f72b5405a736ad92525be3843ea1cf4b5ea5839721cc6d6b358f19bc
DIST ppsspp-1.13.2.tar.gz 31676739 BLAKE2B 913c5be8a40286103f402cd369edb3f8709745204b32f076206532b2bdadd286cd10980009a9613e06537fb62b3e560026631030183362e64b60263c2c1884fd SHA512 09c9fb12e03fb573bb4ac801a807dfbe883316e184750461752d986d00358f4e61153737a5018dd16d8c3082be88566878b3e3357e27267184f8bf4287695227
DIST ppsspp-1.13.tar.gz 31675858 BLAKE2B bfad05d3097481699f555ed16582731a512d14ab36214470d76c5437f7d0d634825546a94eb511568cf291e1a785a3ac392222aa3cc01db6a063816d4e7ee551 SHA512 73233c3da6787808696fa961d9c42127e893be088ecb7eb6d2767392b94eccf35b39c476d17973dd2a34891feb17ca33883b50f90f5e90cf9e758bae1a32452f
+DIST ppsspp-1.14.tar.xz 46411788 BLAKE2B 30333f0b3a0bdf1064b82778e10f300145a6a958f80f6384201c4bbfd4387b2d7e4cbe9863d5ebc823d433efc9fb68090eb39b7051b21a3ae1dd6f92ba6d3f1a SHA512 e8c9a12f480b71da39d9d3caf8d4be30159c02fed2277ee671689236538ce1421bfdf6525f6488087e7c47b11d5de5de78d9b0404b9da579f2bbf25648dc97b2
diff --git a/games-emulation/ppsspp/ppsspp-1.14.ebuild b/games-emulation/ppsspp/ppsspp-1.14.ebuild
new file mode 100644
index 000000000000..a7476deb8679
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="discord qt5"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ dev-util/glslang:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg:0/56.58.58
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-CMakeLists-flags.patch
+ "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DHEADLESS=false
+ -DUSE_DISCORD=$(usex discord)
+ -DUSE_SYSTEM_FFMPEG=ON
+ -DUSE_SYSTEM_LIBZIP=ON
+ -DUSE_SYSTEM_SNAPPY=ON
+ -DUSE_SYSTEM_ZSTD=ON
+ -DUSING_QT_UI=$(usex qt5)
+ )
+ cmake_src_configure
+}