summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-01 23:14:58 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-01 23:23:16 +0900
commit6e4df795f84fc1a29621fad200fd193ba447e879 (patch)
tree0461b0fb84ba3a4f45bc08c22afc59f67f791a1a
parentapp-i18n/ibus: call dconf update (diff)
downloadgentoo-6e4df795f84fc1a29621fad200fd193ba447e879.tar.gz
gentoo-6e4df795f84fc1a29621fad200fd193ba447e879.tar.bz2
gentoo-6e4df795f84fc1a29621fad200fd193ba447e879.zip
app-i18n/ibus: add libnotify USE flag
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-i18n/ibus/ibus-1.5.12.ebuild17
-rw-r--r--app-i18n/ibus/ibus-1.5.15.ebuild17
2 files changed, 22 insertions, 12 deletions
diff --git a/app-i18n/ibus/ibus-1.5.12.ebuild b/app-i18n/ibus/ibus-1.5.12.ebuild
index 55ba530a0565..ebad2ff67aaa 100644
--- a/app-i18n/ibus/ibus-1.5.12.ebuild
+++ b/app-i18n/ibus/ibus-1.5.12.ebuild
@@ -14,8 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="gconf +gtk +gtk2 +introspection nls +python test vala wayland +X"
-REQUIRED_USE="python? (
+IUSE="gconf +gtk +gtk2 +introspection +libnotify nls +python test vala wayland +X"
+REQUIRED_USE="libnotify? ( gtk )
+ python? (
${PYTHON_REQUIRED_USE}
gtk
introspection
@@ -28,7 +29,6 @@ CDEPEND="app-text/iso-codes
gnome-base/dconf
gnome-base/librsvg:2
sys-apps/dbus[X?]
- x11-libs/libnotify
gconf? ( gnome-base/gconf:2 )
gtk? (
x11-libs/gtk+:3
@@ -37,6 +37,7 @@ CDEPEND="app-text/iso-codes
gtk2? ( x11-libs/gtk+:2 )
)
introspection? ( dev-libs/gobject-introspection )
+ libnotify? ( x11-libs/libnotify )
nls? ( virtual/libintl )
python? (
${PYTHON_DEPS}
@@ -60,13 +61,16 @@ RDEPEND="${CDEPEND}
)
)"
DEPEND="${CDEPEND}
+ $(vala_depend)
dev-util/intltool
virtual/pkgconfig
- nls? ( sys-devel/gettext )
- vala? ( $(vala_depend) )"
+ nls? ( sys-devel/gettext )"
src_prepare() {
- use vala && vala_src_prepare
+ vala_src_prepare --ignore-use
+ if ! use libnotify; then
+ touch ui/gtk3/panel.vala
+ fi
# for multiple Python implementations
sed -i "s/^\(PYGOBJECT_DIR =\).*/\1/" bindings/Makefile.am
# fix for parallel install
@@ -105,6 +109,7 @@ src_configure() {
$(use_enable gtk ui) \
$(use_enable gtk2) \
$(use_enable introspection) \
+ $(use_enable libnotify) \
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable vala) \
diff --git a/app-i18n/ibus/ibus-1.5.15.ebuild b/app-i18n/ibus/ibus-1.5.15.ebuild
index afed2d1f73d5..7dc6dcd6bedc 100644
--- a/app-i18n/ibus/ibus-1.5.15.ebuild
+++ b/app-i18n/ibus/ibus-1.5.15.ebuild
@@ -14,8 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="gconf +gtk +gtk2 +introspection nls +python test vala wayland +X"
-REQUIRED_USE="python? (
+IUSE="gconf +gtk +gtk2 +introspection +libnotify nls +python test vala wayland +X"
+REQUIRED_USE="libnotify? ( gtk )
+ python? (
${PYTHON_REQUIRED_USE}
gtk
introspection
@@ -28,7 +29,6 @@ CDEPEND="app-text/iso-codes
gnome-base/dconf
gnome-base/librsvg:2
sys-apps/dbus[X?]
- x11-libs/libnotify
gconf? ( gnome-base/gconf:2 )
gtk? (
x11-libs/gtk+:3
@@ -37,6 +37,7 @@ CDEPEND="app-text/iso-codes
gtk2? ( x11-libs/gtk+:2 )
)
introspection? ( dev-libs/gobject-introspection )
+ libnotify? ( x11-libs/libnotify )
nls? ( virtual/libintl )
python? (
${PYTHON_DEPS}
@@ -60,13 +61,16 @@ RDEPEND="${CDEPEND}
)
)"
DEPEND="${CDEPEND}
+ $(vala_depend)
dev-util/intltool
virtual/pkgconfig
- nls? ( sys-devel/gettext )
- vala? ( $(vala_depend) )"
+ nls? ( sys-devel/gettext )"
src_prepare() {
- use vala && vala_src_prepare
+ vala_src_prepare --ignore-use
+ if ! use libnotify; then
+ touch ui/gtk3/panel.vala
+ fi
# for multiple Python implementations
sed -i "s/^\(PYGOBJECT_DIR =\).*/\1/" bindings/Makefile.am
# fix for parallel install
@@ -101,6 +105,7 @@ src_configure() {
$(use_enable gtk ui) \
$(use_enable gtk2) \
$(use_enable introspection) \
+ $(use_enable libnotify) \
$(use_enable nls) \
$(use_enable test tests) \
$(use_enable vala) \