summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-10-22 18:17:17 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-10-22 18:17:17 +0300
commit6e5072dce92397274fe53c96906a83a081bfde5f (patch)
tree308903e859c8776e260c9e214a77796d849ff534
parentpackage.mask: Last rite dev-python/cheetah-docs (diff)
downloadgentoo-6e5072dce92397274fe53c96906a83a081bfde5f.tar.gz
gentoo-6e5072dce92397274fe53c96906a83a081bfde5f.tar.bz2
gentoo-6e5072dce92397274fe53c96906a83a081bfde5f.zip
app-emulation/lxc: fix 4.0.11 compile failure with bash-completion.pc
- reported by arthurzam, - temporary fix, needs a full patch. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/lxc/lxc-4.0.11.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-emulation/lxc/lxc-4.0.11.ebuild b/app-emulation/lxc/lxc-4.0.11.ebuild
index 65cb5e5ee843..0a763d495217 100644
--- a/app-emulation/lxc/lxc-4.0.11.ebuild
+++ b/app-emulation/lxc/lxc-4.0.11.ebuild
@@ -80,6 +80,8 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
src_prepare() {
default
+
+ export bashcompdir="/etc/bash_completion.d"
eautoreconf
}
@@ -140,7 +142,7 @@ src_install() {
rm -r "${ED}"/etc/bash_completion.d || die "Failed to remove wrong bash_completion.d content."
if use tools; then
- bashcomp_alias lxc-start lxc-{attach,cgroup,copy,console,create,destroy,device,execute,freeze,info,monitor,snapshot,stop,unfreeze,wait}
+ bashcomp_alias lxc-start lxc-{attach,cgroup,copy,console,create,destroy,device,execute,freeze,info,monitor,snapshot,stop,unfreeze,usernsexec,wait}
else
bashcomp_alias lxc-start lxc-usernsexec
fi