summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-07 09:26:46 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-07 09:27:20 +0100
commit6e5159fd33da52961a5eb91588983dc228f9cffd (patch)
tree4c478885c40808aac983ddaa5192e1977379f327
parentmedia-libs/oneVPL: add 2023.1.3 (diff)
downloadgentoo-6e5159fd33da52961a5eb91588983dc228f9cffd.tar.gz
gentoo-6e5159fd33da52961a5eb91588983dc228f9cffd.tar.bz2
gentoo-6e5159fd33da52961a5eb91588983dc228f9cffd.zip
media-libs/oneVPL-cpu: add 2023.1.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--media-libs/oneVPL-cpu/Manifest1
-rw-r--r--media-libs/oneVPL-cpu/oneVPL-cpu-2023.1.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/oneVPL-cpu/Manifest b/media-libs/oneVPL-cpu/Manifest
index 2208fcb9f814..1977480f15b4 100644
--- a/media-libs/oneVPL-cpu/Manifest
+++ b/media-libs/oneVPL-cpu/Manifest
@@ -1,2 +1,3 @@
DIST oneVPL-cpu-2023.1.1.tar.gz 9917709 BLAKE2B 2e30f8e8e493b4027089031ea9434dd04e2ca4dc75d56083259077ef6f2b906c4419451592ce7d272af689c9e46f5dafe2a1552564e77a8012eb4881edc6afc2 SHA512 d294268f45dd59ebae43f3845641c39ecdea39055b9b2fb0fa660e7a3c809ba675f52a23a4cfb67b7c6e6dc0ea200aeb43d3313aeb70efa2b5027eec3d25e5f8
DIST oneVPL-cpu-2023.1.2.tar.gz 10130122 BLAKE2B 4f78258071cbcfb3bf5357bce86e4f2c5d6551800a3f98589d130efc106a83dcaa298d621564cd0c362f227759417a0f6bb6037e6caff4a6f8fa8bfc20c0cde0 SHA512 e206589b8f8b57094e7c850ba2de26fa777e1d90985187d49a26753525ce80fc380cff538a6c4fe67db00314252c56afcca35081e9d39f7a80d1e59b1e7617af
+DIST oneVPL-cpu-2023.1.3.tar.gz 10138929 BLAKE2B bbbe20e7434abcf713fe43d7c1974bba20864fc8ab9087d5e22f82483500738190aaa7a4204ba68c4bcdb1d11552156df97485da09ef9f1084d7c3c60797b178 SHA512 6b9f4a350c771ad5e509f1d39aee67acc5d6501f62741855d3a13f41c29ee1c06b8d885873db2373a5413a0efc349eceaf915ddc789b5ef7da8bf4dfe21ae0d6
diff --git a/media-libs/oneVPL-cpu/oneVPL-cpu-2023.1.3.ebuild b/media-libs/oneVPL-cpu/oneVPL-cpu-2023.1.3.ebuild
new file mode 100644
index 000000000000..513675dc8a74
--- /dev/null
+++ b/media-libs/oneVPL-cpu/oneVPL-cpu-2023.1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="oneAPI Video Processing Library CPU implementation"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL-cpu"
+SRC_URI="https://github.com/oneapi-src/oneVPL-cpu/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT x264? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="experimental openh264 test +x264"
+REQUIRED_USE="^^ ( openh264 x264 )"
+# RESTRICT="!test? ( test )"
+# Tests fail
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ media-libs/dav1d
+ media-libs/oneVPL[experimental?]
+ media-libs/svt-av1
+ media-libs/svt-hevc
+ media-video/ffmpeg
+ x264? ( media-libs/x264 )
+ openh264? ( media-libs/openh264 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2022.2.5-use-system-libs.patch"
+ "${FILESDIR}/${PN}-2022.2.5-respect-user-flags.patch"
+)
+
+src_configure() {
+ # Use system libraries
+ export VPL_BUILD_DEPENDENCIES="${ESYSROOT}/usr"
+ local mycmakeargs=(
+ -DUSE_EXPERIMENTAL_API="$(usex experimental)"
+ -DBUILD_OPENH264="$(usex openh264)"
+ -DBUILD_TESTS="$(usex test)"
+ -DBUILD_GPL_X264="$(usex x264)"
+ # Use FHS instead
+ -DUSE_ONEAPI_INSTALL_LAYOUT=NO
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove these license files
+ rm -r "${ED}/usr/share/oneVPL-cpu/licensing" || die
+}