summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 20:39:22 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 21:00:05 -0500
commit6e519ab08f5687a229f8eea79dfdeb831fea4747 (patch)
treeaf51d6b403ea8902ae648013fd3091b5bc9a9466
parentx11-themes/adwaita-icon-theme: Version bump to 41.0 (diff)
downloadgentoo-6e519ab08f5687a229f8eea79dfdeb831fea4747.tar.gz
gentoo-6e519ab08f5687a229f8eea79dfdeb831fea4747.tar.bz2
gentoo-6e519ab08f5687a229f8eea79dfdeb831fea4747.zip
net-libs/libmbim: Version bump to 1.26.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libmbim/Manifest1
-rw-r--r--net-libs/libmbim/libmbim-1.26.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libmbim/Manifest b/net-libs/libmbim/Manifest
index 9fca404f8e11..c0c7e32c9ab7 100644
--- a/net-libs/libmbim/Manifest
+++ b/net-libs/libmbim/Manifest
@@ -1,2 +1,3 @@
DIST libmbim-1.24.8.tar.xz 517872 BLAKE2B ba4d44ea18ecb412d046b1c1cbd1167bd1cf0a1430486dbf760731950b088e66b25c5c870f2e1a49ea78e43bc15fdbac9efed56afa35127d33f6377325677386 SHA512 32a1ed379fb2799c8490058a16f819620290c2a08d0dacacdc7db4a31fb66a4d9c449b4b2d8fd6de898da28815a6c32e3d97a802970115ac2869e7fec0d841af
DIST libmbim-1.26.0.tar.xz 554672 BLAKE2B b020ea81d6f06bad4c655b285423075873ea01ad253c8eb79fe6e0ce8511d6a8c684c4d8541a64dcc23b46211de117f867d5b405f08942e904156304ce746779 SHA512 b987b3271166eabda7d6767b4b3cd8f34b07ea6a43d5ed1d7cf083561b0e57affeec175a155e5bf8b998dd60f49a303cf54ad6eda146df7483cabe099c401c27
+DIST libmbim-1.26.2.tar.xz 561096 BLAKE2B 11e5339b63dbaca8fb6d31ce2afaf4897774aa4b531cfbb09bb400f64ab975495093b711d0a836feff86e3d9fc72ae2b85ab5cd84fab3d266e0fecf1129125d0 SHA512 7cce1fa6ff5630a1cc565a2198544de9f4a1db20b30304fac96de6c698eaf56b17fe6ccb089151623d4484d88fda6abe980bced19dfbf0d3ef425fc954fb5844
diff --git a/net-libs/libmbim/libmbim-1.26.2.ebuild b/net-libs/libmbim/libmbim-1.26.2.ebuild
new file mode 100644
index 000000000000..fc51435b2a20
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.26.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-libs/glib-2.56:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-Werror \
+ --disable-static \
+ --disable-gtk-doc
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}