summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-02 15:36:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-02 15:54:22 +0100
commit6e5ee50e841bf83918f21b20b90e932a0bb92465 (patch)
treedc5ccea6a007a19fc1c31902f2186346705a2256
parentdev-python/zope-schema: Bump to 7.0.0 (diff)
downloadgentoo-6e5ee50e.tar.gz
gentoo-6e5ee50e.tar.bz2
gentoo-6e5ee50e.zip
dev-python/watchdog: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-2.2.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index aa812ab1b350..12fb58911f27 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1,2 +1,3 @@
DIST watchdog-2.1.9.gh.tar.gz 102882 BLAKE2B 601c94541846e0d63a39367040ac9b6a24c2920c70638ee3887a51838dd75bf8dfef8afae34c9566047c27502026d944f01c6f6249090f4a233a4892fc1e7c59 SHA512 1005c48b08968db7705acbb8a94a0852c72d8bcf45ac935e7e0b49daa6e422adb081cf431485618b37bcc1b2d3429369af1672b826bf9c1ebfa7aff91a88175a
DIST watchdog-2.2.0.gh.tar.gz 101317 BLAKE2B e597b780f26794bfe0462bcb67985d6e38324aac955f8655e657d800039d98473444ff13ea98fbfb6e8a5fd5473c0f3eeda2e542ef030539fc1acc3f86412354 SHA512 95c355da3a97f7eb0ddff02c1801eeafb075aead742d5505254fccef60afd8e5f1ea56760533bb87f520fa60f4f41e4f36c7f02247a170029bace728e83e2780
+DIST watchdog-2.2.1.gh.tar.gz 101485 BLAKE2B 4ec0a2c14d0dcb8d39ed4dea48c1318474768298b4eade4f7c08f811282ffdbf5871c7d55d71681863c38d1f0603c46aaadda73bf38a20ef263fa3b4cf76c354 SHA512 bbd6e3e3fdc7ee5df21b78241922c0050aeb0c01e394fa7d025465f04f3307d190af4cf6e822826975a3b095fb479dfd103be0675f12782e8899f556797baed4
diff --git a/dev-python/watchdog/watchdog-2.2.1.ebuild b/dev-python/watchdog/watchdog-2.2.1.ebuild
new file mode 100644
index 000000000000..5bc9bb951a92
--- /dev/null
+++ b/dev-python/watchdog/watchdog-2.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="
+ https://github.com/gorakhargosh/watchdog/
+ https://pypi.org/project/watchdog/
+"
+SRC_URI="
+ https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ default
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires root powers via sudo (yes, seriously)
+ tests/test_inotify_buffer.py::test_unmount_watched_directory_filesystem
+ )
+
+ epytest -p no:django
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}