summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-11 09:36:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-11 09:56:33 +0200
commit6e6ac89be83e00a82d5916048ad2d3cc2cfc4620 (patch)
tree61ef866a4913a31899d07c2bd5b1f14f9d3ec173
parentdev-python/botocore: Bump to 1.20.70 (diff)
downloadgentoo-6e6ac89be83e00a82d5916048ad2d3cc2cfc4620.tar.gz
gentoo-6e6ac89be83e00a82d5916048ad2d3cc2cfc4620.tar.bz2
gentoo-6e6ac89be83e00a82d5916048ad2d3cc2cfc4620.zip
dev-python/boto3: Bump to 1.17.70
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.70.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index eeaf416022ae..587f9859e691 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.17.65.tar.gz 367905 BLAKE2B d6aa552a8f5a40613577dcb4d43de185662799f
DIST boto3-1.17.67.tar.gz 368242 BLAKE2B 72e612816c45d49c74430d82f4ede59f6b6e7c128d5cb60b8f7d0f07808776b2a1b7656fa8acdf1b8c0d18b4b0a33479aeeebb57355b07ea2e9b6970f84bc4e0 SHA512 a80ea576a60c21f67f43a556ebead8caffcfd18fb9e777693375f591c5e842bfefff86d0d15252057b7ec1ef5cc54b66019d023880a30c88bc8bce012c9b063d
DIST boto3-1.17.68.tar.gz 368708 BLAKE2B 4ed78bae6e8c9ee6e8f1a5a4009f89b1c5efac1ddfa8189a6ec76f1ba47b8113dd479ed935e1d6f4631fcd1e40659398a5189bab77b15e1efe5acf706871b90f SHA512 c8a4a78da518530b3e47c1f3e37f51a61070f9b626b29ee4b1a990bfb2dfce49332add6674a0ec8b156c50e922736a500f2b265cf9ba286000aca55a272a7257
DIST boto3-1.17.69.tar.gz 369006 BLAKE2B 6ad2e9ccb71872c5936f63b786b4b7addd5ff6ff9ccc9b8a65361006ae77861175692fd8a7d4075cf170f92aac4c0f3072a598a99191356909cd95122c34d3ba SHA512 7dfe8ceb621a63ac3e2c2d0852d8ba380200cd91f9f548109c8c5f6b0704a5c56acb645cdec6b7974bb30402a5832d001f5cc9e8d30f940560a06f88407c5385
+DIST boto3-1.17.70.tar.gz 369851 BLAKE2B 31416aed68f340842962dca12f77e169f87f2f2a63fa5189c298678d0672f1edf349e0884856624faa971dd2e1c248e320c92dc8189fc63612cce24680971e5c SHA512 fa0bbcdc9027f09007780f75d3a41aef7656c934bc10f710f5787fd7cd7a7124475437e62e7d507e24f773668102a75c4b3b5cfffa5d2834f75fa930894ce227
diff --git a/dev-python/boto3/boto3-1.17.70.ebuild b/dev-python/boto3/boto3-1.17.70.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.70.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}