summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:17:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:18:14 +0100
commit6e7277d36fdbd6bb66f814c897ce7506935671ac (patch)
tree1b585a42b319415f35b962ce4c1728aedd13f33e
parentdev-python/coloredlogs: update EAPI 7 -> 8, pep517, enable py3.11 (diff)
downloadgentoo-6e7277d36fdbd6bb66f814c897ce7506935671ac.tar.gz
gentoo-6e7277d36fdbd6bb66f814c897ce7506935671ac.tar.bz2
gentoo-6e7277d36fdbd6bb66f814c897ce7506935671ac.zip
dev-python/humanfriendly: enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
new file mode 100644
index 000000000000..c39fcb139268
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/
+ https://github.com/xolox/python-humanfriendly/
+ https://humanfriendly.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+# This is completely broken
+# AttributeError: module 'humanfriendly.tests' has no attribute 'connect'
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-15.0.1[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ epytest humanfriendly/tests.py
+}