summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-07-29 00:49:29 -0400
committerTim Harder <radhermit@gentoo.org>2017-07-29 00:51:16 -0400
commit6e9a8e31660f7ec2d818ba19d74d196bcf6a3d9e (patch)
tree85036311181f3f49b4a8d65adf937d180d913763
parentdev-util/eric: version bump 17.07 (diff)
downloadgentoo-6e9a8e31660f7ec2d818ba19d74d196bcf6a3d9e.tar.gz
gentoo-6e9a8e31660f7ec2d818ba19d74d196bcf6a3d9e.tar.bz2
gentoo-6e9a8e31660f7ec2d818ba19d74d196bcf6a3d9e.zip
net-proxy/sshuttle: version bump to 0.78.3
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/sshuttle-0.78.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index d8cd79c2f66e..37a630dd96f8 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-0.78.1.tar.gz 67173 SHA256 03a71648ce476de06a075bd9a972492d494b414ae51304bf535b80ff22be2d3c SHA512 506b01f20d152e97a41c93299f47d6bba4d7f9fda11e066aca3d79426be68790ff30a3a081ea05ca538aba921ed69e711b672fcfd9084aba6bdae6498beb7e8d WHIRLPOOL d356bf17ba5f6f01351dc316745af3fd07237160340f675e1ecef52d73cb15caf4c5eee65d1ed56ea4008081623362688957f268da30d487d5aa6be02632ddda
+DIST sshuttle-0.78.3.tar.gz 69460 SHA256 8aa31a645e6532d381d0298071960845fbdfa5c7683649a765a7ac7360c1be8b SHA512 581955d9868bdd369a37386b273d53448944b1fb5458a25d5930b348630521cadcaea8cf45371942f96c789889d2a405e8bbe824af3d0c6def73f017f1149a1e WHIRLPOOL 33e1f57ecefcce46240569554e623ae0865cc034232735b4361baf6e43f027b2b2be6ef54120944d3eb7281baecc376cd2a4cbede3b51d2bb8340eeb5e40a89c
diff --git a/net-proxy/sshuttle/sshuttle-0.78.3.ebuild b/net-proxy/sshuttle/sshuttle-0.78.3.ebuild
new file mode 100644
index 000000000000..7afb04c1fa06
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.78.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit linux-info distutils-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.python.org/pypi/sshuttle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-firewall/iptables
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+python_prepare_all() {
+ # don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Tests fail under ${EPYTHON}"
+}