summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 20:58:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:24:39 +0200
commit6ea5973731eddc261201299b3824e5f63f628d5a (patch)
tree3e18f17f40d901d6a8aad9a0255d081ce574bfdb
parentdev-python/pandas: Sync keywords to dev-python/pyarrow (diff)
downloadgentoo-6ea5973731eddc261201299b3824e5f63f628d5a.tar.gz
gentoo-6ea5973731eddc261201299b3824e5f63f628d5a.tar.bz2
gentoo-6ea5973731eddc261201299b3824e5f63f628d5a.zip
kde-frameworks/frameworkintegration: 5.116.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.116.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 417444d9e98e..6c50b0e7409e 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.115.0.tar.xz 1760436 BLAKE2B 59127e732c3b1786e54a079315bf7d47b5025bd653348c67c167afdc2b6291ceb595d85f49c62cc080475fb0963851c07fd95aa2c344b8f0cc76610b701b5be8 SHA512 83cc9d4e1063cd1496dbe373f30f706dcb2ce2515735d7b82cd45cf35b20a8e6c51625b752c6e9a53033db1b0573f2f3159bd569becc707b3a2e7250ce7fd20a
+DIST frameworkintegration-5.116.0.tar.xz 1760428 BLAKE2B 2b9aa2b6776549b333f858eceaa8086adb4e43f67298b1be858e90f6e230027ab1c99693590aa504b70f91dfa725a10872fbda1a104213e8bc9f5d95781ae83b SHA512 425fd38f87b2bba96f68afb8bc8108f9da6011106e33f32b2d91b97b8330d54d0bdc26bec8ecf50c32471d8f8e85af5f6d8b3feee0815225f5dd2075c41c8a83
DIST frameworkintegration-6.2.0.tar.xz 54812 BLAKE2B 09299a498a7d0c2367dbb491e66ea28b815a8665f5feb6548f288cc52481dcdba6841297afd192d352da79d68385fd6e4299ec9e42554b7035ca3b6f2d66e577 SHA512 cf1c3659e603bf52c4a45a5c7533022f5969900ced43725fbe0e86c47c278266b2d78cf86f7afcc69e912d4d85849a28c240d40b18379a6304a297928cabb3d9
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.116.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.116.0.ebuild
new file mode 100644
index 000000000000..a35185a075f4
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.116.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}