summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-27 07:09:43 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-27 07:21:31 +0200
commit6ea856d9e77d583ba373b159e70b2c6cbc01a3be (patch)
treef4d58246ac6ec21119d9e346ee04ff9f72b3247b
parentdev-libs/crypto++: fix subslot number (diff)
downloadgentoo-6ea856d9.tar.gz
gentoo-6ea856d9.tar.bz2
gentoo-6ea856d9.zip
dev-ruby/hoe: add 3.18.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-ruby/hoe/Manifest1
-rw-r--r--dev-ruby/hoe/hoe-3.18.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/hoe/Manifest b/dev-ruby/hoe/Manifest
index 9a88d8b9e7e5..8f456fc26c80 100644
--- a/dev-ruby/hoe/Manifest
+++ b/dev-ruby/hoe/Manifest
@@ -1,3 +1,4 @@
DIST hoe-3.16.0.gem 188416 BLAKE2B 48383c46512a359a269ca3475ec701b1443e0ef71b31d1ca1604de391ed4df6b0ad27dd1c5f6ed04751047d211f2c6299245361cf131e2418f224324ac9934c3 SHA512 66cefb5a24906e19bbf0c82c8539d6d101b84d0dc1d3ce1910e4117357639489968271e76e86bd3c432b9ef7e3b24a78294c06210cbef280860f7dac18100606
DIST hoe-3.17.1.gem 188416 BLAKE2B 0fef6dd9ae4bda93f527d7451d0d591cdc4ba1361aaec531f82e0d7ff03575845c3d5ff85189d76f9ecec17797774fd0ca82f7332a4588d086a494095af99a9d SHA512 5e4b83309ed88da098a5ae8698f9686cea1657f4554fff72446bac46bc567125232a3c5a5b941bd6d5ea18dc53f3cbf5b329f2f0623ef74e81d81586edc63ca3
DIST hoe-3.17.2.gem 188416 BLAKE2B a6f4f93cc2d724b1c1e855c4e6976b5dbb469c4e10fc9c181b6cafaeb7088f9c19bd4bb5b858a25f011dead1b6e8392d349fe9e86d704a6a4d627cddab8de46a SHA512 d6703cd8913ac7055c33dbfead5610bd197be90ac3aeeaf2e4498ab088447d7e08dbe1ad3fdc602afd26fc7cfda12d73dd43a605b9bf59ecd83b1cfd8845f55b
+DIST hoe-3.18.0.gem 190976 BLAKE2B 227dab02241ffa1992fd80d357fcc8ec12a703413a25f38e7c22d97a187b968d334db7fe6b5d49ebe6027b05df660530dab9dd470bbd5816e7e766d86c4de94d SHA512 87b24dd77200a6013eca50b57c001c437035ab5e74809a941a28616d9a722b130a624f1137d7c55eacccc497c5c57f2ccfe872d160915b1a00a71cdf2e76695b
diff --git a/dev-ruby/hoe/hoe-3.18.0.ebuild b/dev-ruby/hoe/hoe-3.18.0.ebuild
new file mode 100644
index 000000000000..2e01454d1f5e
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.18.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Gem.bin_wrapper does not work as expected on Gentoo.
+ sed -i -e 's/#{Gem.bin_wrapper "rdoc"}/-S rdoc/' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+
+ # Avoid test with random sort order
+ sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+ fi
+}